summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-18 07:16:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-18 07:16:37 +0000
commit1b9bdd32d6dd5bf76fa18c0cba5224a834a14fd1 (patch)
tree09e5ab06417fa735eedae2638693eee33b0c734a /games-rpg
parentFix for tests, upstream didn't correct test according to code changes (diff)
downloadgentoo-2-1b9bdd32d6dd5bf76fa18c0cba5224a834a14fd1.tar.gz
gentoo-2-1b9bdd32d6dd5bf76fa18c0cba5224a834a14fd1.tar.bz2
gentoo-2-1b9bdd32d6dd5bf76fa18c0cba5224a834a14fd1.zip
Fix build with gcc-4.6 Bug #363731
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/adonthell/ChangeLog8
-rw-r--r--games-rpg/adonthell/adonthell-0.3.5.ebuild7
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch13
3 files changed, 23 insertions, 5 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index fe656f30bcd4..c4bf1c628d84 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/adonthell
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.21 2010/05/04 22:04:36 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.22 2011/04/18 07:16:37 tupone Exp $
+
+ 18 Apr 2011; Tupone Alfredo <tupone@gentoo.org> adonthell-0.3.5.ebuild,
+ +files/adonthell-0.3.5-gcc46.patch:
+ Fix build with gcc-4.6 Bug #363731 by Diego Elio Pettenò
04 May 2010; Tupone Alfredo <tupone@gentoo.org> adonthell-0.3.5.ebuild:
Force python2 fixing bug #312271 by arfrever@gentoo.org
diff --git a/games-rpg/adonthell/adonthell-0.3.5.ebuild b/games-rpg/adonthell/adonthell-0.3.5.ebuild
index 78b31bfb9445..12f0e7c1779a 100644
--- a/games-rpg/adonthell/adonthell-0.3.5.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.5.ebuild,v 1.5 2010/05/04 22:04:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.5.ebuild,v 1.6 2011/04/18 07:16:37 tupone Exp $
PYTHON_DEPEND="2"
EAPI=2
inherit autotools eutils python games
@@ -40,7 +40,8 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/${P}-configure.in.patch \
- "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
sed -i \
-e "/AC_PATH_PROGS/s:python:$(PYTHON):" \
configure.in || die "sed failed"
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch b/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch
new file mode 100644
index 000000000000..f4d07e867e48
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch
@@ -0,0 +1,13 @@
+--- src/win_event.cc.old 2011-04-18 08:24:16.000000000 +0200
++++ src/win_event.cc 2011-04-18 08:25:18.000000000 +0200
+@@ -34,8 +34,9 @@
+
+ case DESTROY:
+ {
++ Functor0wRet<bool> func0ret;
+ set_callback_destroy (
+- makeFunctor (&Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
++ makeFunctor (&func0ret, *callback, &py_callback::callback_func0ret));
+ break;
+ }
+