summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-24 15:45:55 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-24 15:45:55 +0000
commit972d946fcdedb4788d2ac81853b8788b2babd9a6 (patch)
tree2ef05deaf155e2001e5a5e7b7cd5ebec23d4f9ba /games-rpg/tmw
parentppc stable 316177 (diff)
downloadgentoo-2-972d946fcdedb4788d2ac81853b8788b2babd9a6.tar.gz
gentoo-2-972d946fcdedb4788d2ac81853b8788b2babd9a6.tar.bz2
gentoo-2-972d946fcdedb4788d2ac81853b8788b2babd9a6.zip
Build with gcc-4.5 Bug #321297
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-rpg/tmw')
-rw-r--r--games-rpg/tmw/ChangeLog6
-rw-r--r--games-rpg/tmw/files/tmw-0.0.29.1-gcc45.patch22
-rw-r--r--games-rpg/tmw/tmw-0.0.29.1.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index 032d0fb47778..0cc66ed2ee2e 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.37 2010/03/02 11:20:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.38 2010/05/24 15:45:55 tupone Exp $
+
+ 24 May 2010; Tupone Alfredo <tupone@gentoo.org> tmw-0.0.29.1.ebuild,
+ +files/tmw-0.0.29.1-gcc45.patch:
+ Build with gcc-4.5 Bug #321297 by flameeyes@gentoo.org
02 Mar 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> tmw-0.0.29.1.ebuild:
x86 stable wrt bug #303483
diff --git a/games-rpg/tmw/files/tmw-0.0.29.1-gcc45.patch b/games-rpg/tmw/files/tmw-0.0.29.1-gcc45.patch
new file mode 100644
index 000000000000..c6cad2a02314
--- /dev/null
+++ b/games-rpg/tmw/files/tmw-0.0.29.1-gcc45.patch
@@ -0,0 +1,22 @@
+--- src/emoteshortcut.cpp.old 2010-05-24 17:17:18.000000000 +0200
++++ src/emoteshortcut.cpp 2010-05-24 17:18:40.000000000 +0200
+@@ -26,7 +26,7 @@
+
+ #include "utils/stringutils.h"
+
+-EmoteShortcut::EmoteShortcut *emoteShortcut;
++EmoteShortcut *emoteShortcut;
+
+ EmoteShortcut::EmoteShortcut():
+ mEmoteSelected(0)
+--- src/itemshortcut.cpp.old 2010-05-24 17:19:37.000000000 +0200
++++ src/itemshortcut.cpp 2010-05-24 17:19:49.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ #include "utils/stringutils.h"
+
+-ItemShortcut::ItemShortcut *itemShortcut;
++ItemShortcut *itemShortcut;
+
+ ItemShortcut::ItemShortcut():
+ mItemSelected(-1)
diff --git a/games-rpg/tmw/tmw-0.0.29.1.ebuild b/games-rpg/tmw/tmw-0.0.29.1.ebuild
index 5a99744aeb76..acbd3b8977e5 100644
--- a/games-rpg/tmw/tmw-0.0.29.1.ebuild
+++ b/games-rpg/tmw/tmw-0.0.29.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.29.1.ebuild,v 1.5 2010/03/02 11:20:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.29.1.ebuild,v 1.6 2010/05/24 15:45:55 tupone Exp $
EAPI=2
inherit eutils games
@@ -38,7 +38,8 @@ src_prepare() {
-e '/^SUBDIRS/s/fonts//' \
data/Makefile.in \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
}
src_configure() {