summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-08-02 11:56:26 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-08-02 11:56:26 +0000
commit6aad6ec2c7b189d9a8eaa6fd72ee4191930e93d6 (patch)
treed41114d7b6bbb6e4f20a297e0ce2e402f9a30fa2 /games-rpg/tmw
parentFix sandbox violation wrt bug 377375 by Vasileios Lourdas <bugzilla@lourdas.n... (diff)
downloadgentoo-2-6aad6ec2c7b189d9a8eaa6fd72ee4191930e93d6.tar.gz
gentoo-2-6aad6ec2c7b189d9a8eaa6fd72ee4191930e93d6.tar.bz2
gentoo-2-6aad6ec2c7b189d9a8eaa6fd72ee4191930e93d6.zip
Version bump to 0.5.2 Bug #363795
(Portage version: 2.1.10.9/cvs/Linux i686)
Diffstat (limited to 'games-rpg/tmw')
-rw-r--r--games-rpg/tmw/ChangeLog10
-rw-r--r--games-rpg/tmw/files/tmw-0.5.2-gentoo.patch31
-rw-r--r--games-rpg/tmw/tmw-0.5.2.ebuild73
3 files changed, 112 insertions, 2 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index 0cc66ed2ee2e..1b575b924e07 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/tmw
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.38 2010/05/24 15:45:55 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.39 2011/08/02 11:56:25 tupone Exp $
+
+*tmw-0.5.2 (02 Aug 2011)
+
+ 02 Aug 2011; Tupone Alfredo <tupone@gentoo.org> +tmw-0.5.2.ebuild,
+ +files/tmw-0.5.2-gentoo.patch:
+ Version bump to 0.5.2 Bug #363795 by Ben Longbons
24 May 2010; Tupone Alfredo <tupone@gentoo.org> tmw-0.0.29.1.ebuild,
+files/tmw-0.0.29.1-gcc45.patch:
diff --git a/games-rpg/tmw/files/tmw-0.5.2-gentoo.patch b/games-rpg/tmw/files/tmw-0.5.2-gentoo.patch
new file mode 100644
index 000000000000..b5f90cb6658c
--- /dev/null
+++ b/games-rpg/tmw/files/tmw-0.5.2-gentoo.patch
@@ -0,0 +1,31 @@
+--- CMakeLists.txt.old 2011-08-02 08:28:51.211645468 +0200
++++ CMakeLists.txt 2011-08-02 08:29:26.912641230 +0200
+@@ -41,9 +41,9 @@
+ IF (NOT OSX)
+ OPTION(USE_X11 "Use X11 Clipboard functionality" ON)
+ ENDIF ()
+- SET(PKG_DATADIR ${CMAKE_INSTALL_PREFIX}/share/mana)
++ SET(PKG_DATADIR @GENTOO_DATADIR@)
+ SET(LOCALEDIR ${CMAKE_INSTALL_PREFIX}/share/locale)
+- SET(PKG_BINDIR ${CMAKE_INSTALL_PREFIX}/bin)
++ SET(PKG_BINDIR @GENTOO_BINDIR@)
+ ENDIF (WIN32)
+
+ ADD_SUBDIRECTORY(data)
+--- mana.desktop.old 2011-08-02 11:31:56.049341650 +0200
++++ mana.desktop 2011-08-02 11:32:05.312340549 +0200
+@@ -13,4 +13,4 @@
+ Terminal=false
+ Type=Application
+ Icon=mana
+-Categories=Application;Game;
++Categories=Game;
+--- data/CMakeLists.txt.old 2011-08-02 12:15:38.520030381 +0200
++++ data/CMakeLists.txt 2011-08-02 12:15:44.971029615 +0200
+@@ -1,6 +1,5 @@
+ SET(DATA_DIR ${PKG_DATADIR}/data)
+
+-ADD_SUBDIRECTORY(fonts)
+ ADD_SUBDIRECTORY(graphics)
+ ADD_SUBDIRECTORY(help)
+ ADD_SUBDIRECTORY(icons)
diff --git a/games-rpg/tmw/tmw-0.5.2.ebuild b/games-rpg/tmw/tmw-0.5.2.ebuild
new file mode 100644
index 000000000000..f6f3baf08582
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.5.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.5.2.ebuild,v 1.1 2011/08/02 11:56:25 tupone Exp $
+
+EAPI=2
+inherit eutils games cmake-utils
+
+MUSIC=tmwmusic-0.3
+
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.bz2
+ mirror://sourceforge/themanaworld/${MUSIC}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls opengl"
+
+RDEPEND=">=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ x11-libs/libX11
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_unpack() {
+ mkdir ${P}
+ cd ${P}
+ unpack ${A}
+}
+
+src_prepare() {
+ base_src_prepare
+ sed -i \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ CMakeLists.txt \
+ || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl)
+ $(cmake-utils_use_enable nls)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+ doins -r ${MUSIC}/data/music || die
+ prepgamesdirs
+}