summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-01-31 21:01:31 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-01-31 21:01:31 +0000
commitee181c11c57458977c39f684bb8850b3a5bb2975 (patch)
tree1d6f936443905d76260343bab2cd3e20c5e150f9 /games-rpg/nwn-cep/nwn-cep-2.0.ebuild
parentStable on ppc64; bug #163699 (diff)
downloadgentoo-2-ee181c11c57458977c39f684bb8850b3a5bb2975.tar.gz
gentoo-2-ee181c11c57458977c39f684bb8850b3a5bb2975.tar.bz2
gentoo-2-ee181c11c57458977c39f684bb8850b3a5bb2975.zip
Added 2.0 ebuild. Ebuild by Benedikt Morbach <benedikt.morbach+bugzilla@googlemail.com> and modified by me. Closing bug #150195.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'games-rpg/nwn-cep/nwn-cep-2.0.ebuild')
-rw-r--r--games-rpg/nwn-cep/nwn-cep-2.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-rpg/nwn-cep/nwn-cep-2.0.ebuild b/games-rpg/nwn-cep/nwn-cep-2.0.ebuild
new file mode 100644
index 000000000000..d2931f835317
--- /dev/null
+++ b/games-rpg/nwn-cep/nwn-cep-2.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-2.0.ebuild,v 1.1 2007/01/31 21:01:31 wolf31o2 Exp $
+
+
+inherit eutils games
+
+DESCRIPTION="The Community Expansion Pack is a high quality custom content addon for Neverwinter Nights"
+HOMEPAGE="http://nwn.bioware.com/players/cep.html"
+SRC_URI="cepv2_Part_A.zip cepv2_Part_B.zip"
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=games-rpg/nwn-1.68"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/nwn
+Ddir=${D}/${dir}
+
+pkg_nofetch() {
+ einfo "Please visit http://nwvault.ign.com/cep/downloads/"
+ einfo "and download the .zip versions of ${A}."
+ einfo "Then move the files you downloaded to:"
+ einfo "${DISTDIR}"
+}
+
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use games-rpg/nwn-data sou || ! built_with_use games-rpg/nwn-data hou
+ then
+ eerror "${P} requires NWN v1.68, Shadows of Undrentide, and Hordes of"
+ eerror "the Underdark. Please make sure you have all three before using"
+ eerror "this patch."
+ die "Requirements not met"
+ fi
+}
+
+src_install() {
+ local i
+ for i in hak tlk erf
+ do
+ insinto "${dir}"/${i}
+ doins *.${i} || die "${i} failed"
+ done
+ insinto "${dir}"/modules
+ doins *.mod || die "mod failed"
+ insinto "${dir}"/cep
+ doins *.pdf || die "pdf failed"
+ prepgamesdirs
+}