summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-05-21 11:34:06 +0000
committerRoy Marples <uberlord@gentoo.org>2006-05-21 11:34:06 +0000
commit8d81c9c5d9a81375ce1db593f6f5f132f5742c8b (patch)
treedcbad8128904fe43f759d8d319397ae1c746cf7c /games-rpg/eternal-lands
parentInstall book xml correctly, #133661 thanks to Jonathan Lambrechts. (diff)
downloadgentoo-2-8d81c9c5d9a81375ce1db593f6f5f132f5742c8b.tar.gz
gentoo-2-8d81c9c5d9a81375ce1db593f6f5f132f5742c8b.tar.bz2
gentoo-2-8d81c9c5d9a81375ce1db593f6f5f132f5742c8b.zip
Only install xml files in the books folder, #133661.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'games-rpg/eternal-lands')
-rw-r--r--games-rpg/eternal-lands/ChangeLog8
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r3.ebuild105
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r36
3 files changed, 118 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index f498d6c66c87..7cf684fc6b0c 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.16 2006/05/11 22:00:58 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.17 2006/05/21 11:34:06 uberlord Exp $
+
+*eternal-lands-1.2.0_p1-r3 (21 May 2006)
+
+ 21 May 2006; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-1.2.0_p1-r3.ebuild:
+ Only install xml files in the books folder, #133661.
*eternal-lands-1.2.0_p1-r2 (11 May 2006)
diff --git a/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r3.ebuild b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r3.ebuild
new file mode 100644
index 000000000000..57e9110bbd2a
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r3.ebuild,v 1.1 2006/05/21 11:34:06 uberlord Exp $
+
+inherit eutils games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tgz
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext )
+ virtual/x11 )
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ =media-libs/cal3d-0.10.0
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-apps/findutils
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="konqueror"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Allow compiled vertex arrays to be togglable as they don't seem to work
+ # with xorg drivers on IGP style cards.
+ epatch "${FILESDIR}/${PN}-1.2.0-vertex-array.patch"
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ -e 's/ -DAUTO_UPDATE//' \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ rm -f books/*.c books/*.o books/*.h
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt *.lst \
+ actor_defs books languages \
+ || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r3 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r3
new file mode 100644
index 000000000000..ec8e42ae0a6d
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r3
@@ -0,0 +1,6 @@
+MD5 15492252c997253a90e6eec4f9edfeae elc_120p1.tgz 731594
+RMD160 a06be332015a8db57c3455f9918e3b58cfe92a41 elc_120p1.tgz 731594
+SHA256 a610102e92e91c6c69c4ceef906ae5010280267a1b9f55ec71f172e3691f0674 elc_120p1.tgz 731594
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955