summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-16 14:46:20 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-16 14:46:20 +0000
commite8d95737b604613847bf3f6db3261690a62022c9 (patch)
tree34aad4d09a011306ee1fb88ba51071b15bf3fa07 /games-rpg/bastion
parentversion bump, remove old: update russian translation, fix zsh completion (diff)
downloadgentoo-2-e8d95737b604613847bf3f6db3261690a62022c9.tar.gz
gentoo-2-e8d95737b604613847bf3f6db3261690a62022c9.tar.bz2
gentoo-2-e8d95737b604613847bf3f6db3261690a62022c9.zip
fix arch logic, fixes #466024
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg/bastion')
-rw-r--r--games-rpg/bastion/ChangeLog8
-rw-r--r--games-rpg/bastion/bastion-20120620-r1.ebuild (renamed from games-rpg/bastion/bastion-20120620.ebuild)30
2 files changed, 18 insertions, 20 deletions
diff --git a/games-rpg/bastion/ChangeLog b/games-rpg/bastion/ChangeLog
index a76e17fd38a0..7023ba0a093f 100644
--- a/games-rpg/bastion/ChangeLog
+++ b/games-rpg/bastion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/bastion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/bastion/ChangeLog,v 1.1 2013/03/21 22:17:15 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/bastion/ChangeLog,v 1.2 2013/04/16 14:46:20 hasufell Exp $
+
+*bastion-20120620-r1 (16 Apr 2013)
+
+ 16 Apr 2013; Julian Ospald <hasufell@gentoo.org> -bastion-20120620.ebuild,
+ +bastion-20120620-r1.ebuild:
+ fix arch logic, fixes #466024
*bastion-20120620 (21 Mar 2013)
diff --git a/games-rpg/bastion/bastion-20120620.ebuild b/games-rpg/bastion/bastion-20120620-r1.ebuild
index bad060defb09..8ca1603aa304 100644
--- a/games-rpg/bastion/bastion-20120620.ebuild
+++ b/games-rpg/bastion/bastion-20120620-r1.ebuild
@@ -1,9 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/bastion/bastion-20120620.ebuild,v 1.2 2013/03/22 21:34:09 hasufell Exp $
-
-# TODO: - unbundle mono when multilib
-# - unbundle fmodex when multilib
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/bastion/bastion-20120620-r1.ebuild,v 1.1 2013/04/16 14:46:20 hasufell Exp $
EAPI=5
@@ -21,18 +18,13 @@ IUSE="bundled-libs"
RESTRICT="bindist fetch"
MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/Bastion.bin.x86
- ${MYGAMEDIR#/}/lib/*"
+QA_PREBUILT="${MYGAMEDIR#/}/Bastion.bin*
+ ${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/lib64/*"
# mono shit: vague dependencies
RDEPEND="
virtual/opengl
- amd64? (
- app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-soundlibs
- app-emulation/emul-linux-x86-xlibs
- )
- x86? (
media-libs/freealut
media-libs/openal
media-libs/sdl-gfx
@@ -47,8 +39,7 @@ RDEPEND="
dev-lang/mono
media-libs/fmod:1
media-libs/libsdl[X,audio,video,opengl,joystick]
- )
- )"
+ )"
CHECKREQS_DISK_BUILD="2400M"
@@ -59,7 +50,7 @@ pkg_nofetch() {
}
src_unpack() {
- local myarch=$(usex amd64 "x86" "x86_64")
+ myarch=$(usex amd64 "x86_64" "x86")
unpack_makeself
@@ -75,8 +66,9 @@ src_unpack() {
src_prepare() {
if ! use bundled-libs ; then
einfo "Removing bundles libs..."
- rm -v lib/libSDL-1.2.so* || die
- use x86 && { rm -v lib/libmono-2.0.so* lib/libfmodex.so* || die ;}
+ rm -v $(get_libdir)/libmono-2.0.so* \
+ $(get_libdir)/libfmodex.so* \
+ $(get_libdir)/libSDL-1.2.so*|| die
fi
}
@@ -86,9 +78,9 @@ src_install() {
newicon -s 256 Bastion.png ${PN}.png
make_desktop_entry ${PN}
- games_make_wrapper ${PN} "./Bastion.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ games_make_wrapper ${PN} "./Bastion.bin.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/$(get_libdir)"
- fperms +x "${MYGAMEDIR}"/Bastion.bin.x86
+ fperms +x "${MYGAMEDIR}"/Bastion.bin.${myarch}
prepgamesdirs
}