summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-09 04:35:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-09 04:35:31 +0000
commit42287ba5750c1c1ffab583e9a28a192261114691 (patch)
treeb7db2d7fc372bc91807435ec669764746c844339 /games-rpg/adonthell
parentmake sure we reset the env in every func (diff)
downloadgentoo-2-42287ba5750c1c1ffab583e9a28a192261114691.tar.gz
gentoo-2-42287ba5750c1c1ffab583e9a28a192261114691.tar.bz2
gentoo-2-42287ba5750c1c1ffab583e9a28a192261114691.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/ChangeLog8
-rw-r--r--games-rpg/adonthell/Manifest5
-rw-r--r--games-rpg/adonthell/adonthell-0.3.4a.ebuild53
-rw-r--r--games-rpg/adonthell/files/0.3.4a-configure.in.patch74
-rw-r--r--games-rpg/adonthell/files/digest-adonthell-0.3.4a1
5 files changed, 139 insertions, 2 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index 69b2de93d1de..1d31b41f6b17 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/adonthell
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.6 2005/03/13 07:50:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.7 2005/06/09 04:35:05 mr_bones_ Exp $
+
+*adonthell-0.3.4a (09 Jun 2005)
+
+ 09 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.3.4a-configure.in.patch, +adonthell-0.3.4a.ebuild:
+ version bump
13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
files/0.3.3-configure.in.patch, adonthell-0.3.3-r1.ebuild:
diff --git a/games-rpg/adonthell/Manifest b/games-rpg/adonthell/Manifest
index 1e5f0ef70f71..8a1625c4e0c0 100644
--- a/games-rpg/adonthell/Manifest
+++ b/games-rpg/adonthell/Manifest
@@ -1,5 +1,8 @@
-MD5 70de9cd37cf0609a8f8c5c57a1a39028 ChangeLog 1399
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 bef65f10e9b0647e3d4fae949f791434 adonthell-0.3.3-r1.ebuild 1225
+MD5 70de9cd37cf0609a8f8c5c57a1a39028 ChangeLog 1399
+MD5 e86da8efaf099ebac6de88646af405f9 adonthell-0.3.4a.ebuild 1277
MD5 f8819f0b8b8a019c2ab89d7c707665eb files/0.3.3-configure.in.patch 2957
+MD5 f8819f0b8b8a019c2ab89d7c707665eb files/0.3.4a-configure.in.patch 2957
+MD5 9b2f86f7d5729fd1944524672760f256 files/digest-adonthell-0.3.4a 72
MD5 e944f3812b6938f625c3a2bba14b3b35 files/digest-adonthell-0.3.3-r1 72
diff --git a/games-rpg/adonthell/adonthell-0.3.4a.ebuild b/games-rpg/adonthell/adonthell-0.3.4a.ebuild
new file mode 100644
index 000000000000..9eec62fd4b9e
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.4a.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.4a.ebuild,v 1.1 2005/06/09 04:35:05 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="roleplaying game engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="doc nls"
+
+RDEPEND="dev-lang/python
+ >=media-libs/freetype-2
+ media-libs/libsdl
+ media-libs/libvorbis
+ media-libs/libogg
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )
+ sys-devel/autoconf"
+
+S=${WORKDIR}/${PN}-${PV/a/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-configure.in.patch"
+ aclocal && automake -a && autoconf || die "autotools failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-py-debug \
+ $(use_enable nls) \
+ $(use_enable doc) \
+ || die
+ touch doc/items/{footer,header}.html
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ keepdir "${GAMES_DATADIR}/${PN}/games"
+ dodoc AUTHORS ChangeLog FULLSCREEN.howto INSTALL NEWBIE NEWS README
+ prepgamesdirs
+}
diff --git a/games-rpg/adonthell/files/0.3.4a-configure.in.patch b/games-rpg/adonthell/files/0.3.4a-configure.in.patch
new file mode 100644
index 000000000000..fd7ad893772c
--- /dev/null
+++ b/games-rpg/adonthell/files/0.3.4a-configure.in.patch
@@ -0,0 +1,74 @@
+--- configure.in.orig 2005-03-12 18:01:25.000000000 -0500
++++ configure.in 2005-03-13 00:12:26.000000000 -0500
+@@ -159,10 +159,8 @@
+
+ dnl Extract the version using Python, check against 1.5+
+
+- changequote(<<, >>)
+- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
+- PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version[0:3]'`
+- changequote([, ])
++ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
++ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
+
+ if test $PYTHON_VERSION -lt 15; then
+ echo "Sorry, you need to have Python 1.5+ installed - update your version!"
+@@ -172,9 +170,7 @@
+ dnl Find the Python.h header file
+
+ AC_MSG_CHECKING(for Python header files)
+- changequote(<<, >>)
+- PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version[:3])'`
+- changequote([, ])
++ PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version@<:@:3@:>@)'`
+
+ if test -r "$PYINCLUDE/Python.h"; then
+ PY_CFLAGS="-I$PYINCLUDE"
+@@ -188,10 +184,8 @@
+
+ AC_MSG_CHECKING(for Python library)
+ PYLIB=""
+- changequote(<<, >>)
+ PYPREFIX=`$PYPACKAGE -c 'import sys; print sys.prefix'`
+- PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version[:3]'`
+- changequote([, ])
++ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
+
+ py_paths="$PYPREFIX/lib/python$PYLIBVER/config $PYPREFIX/lib"
+ py_suffix="$PYLIBVER.so $PYLIBVER.a .so .a"
+@@ -220,19 +214,9 @@
+
+ dnl Get the libraries that python depends on
+
+- AC_PATH_PROG(haveldd, ldd)
+ AC_MSG_CHECKING(for Python's dependencies)
+
+- if test x$haveldd != x ; then
+- changequote(<<, >>)
+- py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v 'stdc++'`
+- for py_lib in $py_deps ; do
+- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
+- PY_DEPS="$PY_DEPS $py_lib"
+- fi
+- done
+- changequote([, ])
+- fi
++ PY_DEPS="$PY_DEPS `python-config --libs`"
+
+ case $target in
+ *-sun-solaris*)
+@@ -280,11 +264,9 @@
+ if test "$P_SWIG" != "no" ; then
+ $P_SWIG -version &> swig.ver
+
+- changequote(<<, >>)
+- swig_major_ver=`more swig.ver | sed 's/.* \([0-9]*\)\.[0-9]*\.[0-9]*.*/\1/p; d'`
+- swig_minor_ver=`more swig.ver | sed 's/.* [0-9]*\.\([0-9]*\)\.[0-9]*.*/\1/p; d'`
+- swig_micro_ver=`more swig.ver | sed 's/.* [0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p; d'`
+- changequote([, ])
++ swig_major_ver=`more swig.ver | sed 's/.* \(@<:@0-9@:>@*\)\.@<:@0-9@:>@*\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_minor_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.\(@<:@0-9@:>@*\)\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_micro_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.@<:@0-9@:>@*\.\(@<:@0-9@:>@*\).*/\1/p; d'`
+
+ rm -f swig.ver
+
diff --git a/games-rpg/adonthell/files/digest-adonthell-0.3.4a b/games-rpg/adonthell/files/digest-adonthell-0.3.4a
new file mode 100644
index 000000000000..032b49e2401e
--- /dev/null
+++ b/games-rpg/adonthell/files/digest-adonthell-0.3.4a
@@ -0,0 +1 @@
+MD5 477ae574374fc9b5e1c5076769c150fe adonthell-src-0.3.4a.tar.gz 680872