summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-14 19:35:03 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-14 19:35:03 +0000
commitd6f3253492641bc73ba4278318e22f6c574bf6ec (patch)
treed32d736a467e83d127c6e7aa4eb7c32126947f79 /games-roguelike
parentremove leading slash from QA_PREBUILT paths (diff)
downloadgentoo-2-d6f3253492641bc73ba4278318e22f6c574bf6ec.tar.gz
gentoo-2-d6f3253492641bc73ba4278318e22f6c574bf6ec.tar.bz2
gentoo-2-d6f3253492641bc73ba4278318e22f6c574bf6ec.zip
version bump
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/FTL/ChangeLog7
-rw-r--r--games-roguelike/FTL/FTL-1.03.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/games-roguelike/FTL/ChangeLog b/games-roguelike/FTL/ChangeLog
index 38ed46cfe287..71a51aaf2ee6 100644
--- a/games-roguelike/FTL/ChangeLog
+++ b/games-roguelike/FTL/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/FTL
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/ChangeLog,v 1.9 2013/05/14 19:30:35 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/ChangeLog,v 1.10 2013/05/14 19:35:03 hasufell Exp $
+
+*FTL-1.03.3 (14 May 2013)
+
+ 14 May 2013; Julian Ospald <hasufell@gentoo.org> +FTL-1.03.3.ebuild:
+ version bump
14 May 2013; Julian Ospald <hasufell@gentoo.org> FTL-1.03.1.ebuild:
add splitdebug restrict
diff --git a/games-roguelike/FTL/FTL-1.03.3.ebuild b/games-roguelike/FTL/FTL-1.03.3.ebuild
new file mode 100644
index 000000000000..d3d44364bdae
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.03.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/FTL-1.03.3.ebuild,v 1.1 2013/05/14 19:35:03 hasufell Exp $
+
+# TODO: update libpng to slot 1.5 when stable
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="http://www.ftlgame.com/"
+SRC_URI="FTL.Linux.${PV}.tar.gz"
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+RDEPEND="
+ =media-libs/libpng-1.5*
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ !bundled-libs? (
+ media-libs/devil[png,opengl]
+ media-libs/freetype:2
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ sys-libs/zlib
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/bin/${PN}
+ ${GAMES_PREFIX_OPT#/}/${PN}/lib/*"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data/resources
+ doins data/exe_icon.bmp
+
+ exeinto "${dir}"/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto "${dir}"/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/exe_icon.bmp FTL.bmp
+ dohtml ${PN}_README.html
+
+ prepgamesdirs
+}