summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-11-02 01:50:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-11-02 01:50:49 +0000
commitce90ee27a555674357ae117c0c7faeb44240f044 (patch)
treeabba087de87ca414574d133f29bd5a7adf92acef /games-roguelike
parentVersion bump. (diff)
downloadgentoo-2-ce90ee27a555674357ae117c0c7faeb44240f044.tar.gz
gentoo-2-ce90ee27a555674357ae117c0c7faeb44240f044.tar.bz2
gentoo-2-ce90ee27a555674357ae117c0c7faeb44240f044.zip
EAPI=5; build with ncurses[tinfo] (bug #527654)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/moria/ChangeLog8
-rw-r--r--games-roguelike/moria/files/5.5.2-glibc.patch2
-rw-r--r--games-roguelike/moria/files/5.5.2-warnings.patch12
-rw-r--r--games-roguelike/moria/moria-5.5.2.ebuild29
4 files changed, 35 insertions, 16 deletions
diff --git a/games-roguelike/moria/ChangeLog b/games-roguelike/moria/ChangeLog
index 3539925cecf4..550e8c7aa28a 100644
--- a/games-roguelike/moria/ChangeLog
+++ b/games-roguelike/moria/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/moria
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/moria/ChangeLog,v 1.9 2010/05/05 20:28:21 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/moria/ChangeLog,v 1.10 2014/11/02 01:50:49 mr_bones_ Exp $
+
+ 02 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/5.5.2-warnings.patch, files/5.5.2-glibc.patch, moria-5.5.2.ebuild:
+ EAPI=5; build with ncurses[tinfo] (bug #527654)
05 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
+files/5.5.2-hours.patch, moria-5.5.2.ebuild:
diff --git a/games-roguelike/moria/files/5.5.2-glibc.patch b/games-roguelike/moria/files/5.5.2-glibc.patch
index 5738d8070cfe..55e4e5de2b14 100644
--- a/games-roguelike/moria/files/5.5.2-glibc.patch
+++ b/games-roguelike/moria/files/5.5.2-glibc.patch
@@ -9,7 +9,7 @@ diff -Naur common-orig/Makefile umoria/unix/Makefile
+# CURSES = -lcurses -ltermcap
# For SYS V Systems
-# CURSES = -lcurses
-+CURSES = -lcurses
++CURSES = `pkg-config ncurses --libs`
# For XENIX, some XENIX systems may need -ltinfo
# CURSES = -ltcap -ltermcap -lx
diff --git a/games-roguelike/moria/files/5.5.2-warnings.patch b/games-roguelike/moria/files/5.5.2-warnings.patch
new file mode 100644
index 000000000000..33a2762b99d0
--- /dev/null
+++ b/games-roguelike/moria/files/5.5.2-warnings.patch
@@ -0,0 +1,12 @@
+diff -ru umoria.orig/unix/unix.c umoria/unix/unix.c
+--- umoria.orig/unix/unix.c 2014-11-01 02:45:07.375535783 -0400
++++ umoria/unix/unix.c 2014-11-01 02:45:58.575820065 -0400
+@@ -315,7 +315,7 @@
+
+ user[0] = '\0';
+ file++;
+- while (*file != '/' && i < sizeof(user))
++ while (*file != '/' && i < sizeof(user) - 1)
+ user[i++] = *file++;
+ user[i] = '\0';
+ if (i == 0)
diff --git a/games-roguelike/moria/moria-5.5.2.ebuild b/games-roguelike/moria/moria-5.5.2.ebuild
index 8f51392922f0..f05ebcbfe207 100644
--- a/games-roguelike/moria/moria-5.5.2.ebuild
+++ b/games-roguelike/moria/moria-5.5.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/moria/moria-5.5.2.ebuild,v 1.12 2010/05/05 20:28:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/moria/moria-5.5.2.ebuild,v 1.13 2014/11/02 01:50:49 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="Rogue-like D&D curses game similar to nethack (BUT BETTER)"
@@ -18,7 +18,9 @@ SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5"
+RDEPEND=">=sys-libs/ncurses-5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S=${WORKDIR}/umoria
@@ -29,7 +31,8 @@ src_prepare() {
"${FILESDIR}"/${PV}-gentoo-paths.patch \
"${FILESDIR}"/${PV}-glibc.patch \
"${FILESDIR}"/${PV}-fbsd.patch \
- "${FILESDIR}"/${PV}-hours.patch
+ "${FILESDIR}"/${PV}-hours.patch \
+ "${FILESDIR}"/${PV}-warnings.patch
for f in source/* unix/* ; do
ln -s ${f} $(basename ${f})
@@ -39,10 +42,11 @@ src_prepare() {
-e "s:David Grabiner:root:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
-e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}:" \
- config.h \
- || die "sed failed"
- echo "#include <stdlib.h>" >> config.h
- echo "#include <stdio.h>" >> config.h
+ config.h || die
+ {
+ echo "#include <stdlib.h>"
+ echo "#include <stdio.h>"
+ } >> config.h || die
sed -i \
-e "/^STATEDIR =/s:=.*:=\$(DESTDIR)${GAMES_STATEDIR}:" \
-e "/^BINDIR = /s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
@@ -52,14 +56,13 @@ src_prepare() {
-e "/^GROUP = /s:=.*:=${GAMES_GROUP}:" \
-e "/^CC = /s:=.*:=$(tc-getCC):" \
-e '/^LFLAGS = /s:=.*:= $(LDFLAGS):' \
- Makefile \
- || die "sed failed"
- mv doc/moria.6 "${S}" || die "mv failed"
+ Makefile || die
+ mv doc/moria.6 "${S}" || die
}
src_install() {
dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}"
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
doman moria.6
dodoc README doc/* "${WORKDIR}"/${PN}-extras/*