summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 00:57:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 00:57:02 +0000
commit7165c6181a17ae128ea40dd5f76c87b78c834058 (patch)
tree2da7d7569d69eaf316b3fc56a48fd435d9ff9dda /games-roguelike
parentFix Xinerama automagic (diff)
downloadgentoo-2-7165c6181a17ae128ea40dd5f76c87b78c834058.tar.gz
gentoo-2-7165c6181a17ae128ea40dd5f76c87b78c834058.tar.bz2
gentoo-2-7165c6181a17ae128ea40dd5f76c87b78c834058.zip
reroll and actually apply patch
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/powder/ChangeLog6
-rw-r--r--games-roguelike/powder/files/powder-113-make.patch130
-rw-r--r--games-roguelike/powder/powder-113.ebuild4
3 files changed, 43 insertions, 97 deletions
diff --git a/games-roguelike/powder/ChangeLog b/games-roguelike/powder/ChangeLog
index d5b4b6040594..5c3d8e4336b9 100644
--- a/games-roguelike/powder/ChangeLog
+++ b/games-roguelike/powder/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/powder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/ChangeLog,v 1.1 2010/05/03 23:56:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/ChangeLog,v 1.2 2010/05/04 00:57:02 mr_bones_ Exp $
+
+ 04 May 2010; Michael Sterrett <mr_bones_@gentoo.org> powder-113.ebuild,
+ files/powder-113-make.patch:
+ reroll and actually apply patch
*powder-113 (03 May 2010)
diff --git a/games-roguelike/powder/files/powder-113-make.patch b/games-roguelike/powder/files/powder-113-make.patch
index 9f6dda709d23..fa39312b6b92 100644
--- a/games-roguelike/powder/files/powder-113-make.patch
+++ b/games-roguelike/powder/files/powder-113-make.patch
@@ -1,107 +1,47 @@
---- powder110_src/make/makerules.origin 2009-01-29 00:32:32.141421840 +0200
-+++ powder110_src/make/makerules 2009-01-29 00:27:37.128428046 +0200
-@@ -1,11 +1,11 @@
- .cpp.o:
-- g++ -O3 -I . -DLINUX -c $< -o $@ $(CXXFLAGS)
-+ $(CXX) -I . -DLINUX -c $< -o $@ $(CXXFLAGS)
-
+diff -ru powder113_src.orig/make/makerules powder113_src/make/makerules
+--- powder113_src.orig/make/makerules 2009-02-05 20:11:41.000000000 -0500
++++ powder113_src/make/makerules 2010-05-03 20:38:32.579540189 -0400
+@@ -8,7 +8,7 @@
all: $(TARGET)
$(TARGET): $(OFILES)
-- g++ -O3 -o $(TARGET) $(OFILES) $(CXXFLAGS)
-+ $(CXX) -o $(TARGET) $(OFILES) $(CXXFLAGS)
+- $(CXX) -o $(TARGET) $(OFILES) $(CXXFLAGS)
++ $(CXX) -o $(TARGET) $(OFILES) $(CXXFLAGS) $(LDFLAGS)
clean:
-- rm -f *.o
-- rm -f $(TARGET)
-+ $(RM) *.o
-+ $(RM) $(TARGET)
---- powder110_src/make/makerules.LINUX.origin 2009-01-28 21:59:57.499759608 +0200
-+++ powder110_src/make/makerules.LINUX 2009-01-29 00:27:34.747275321 +0200
-@@ -1,5 +1,5 @@
- .cpp.o:
-- g++ -O3 -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $< -o $@ $(CXXFLAGS)
-+ $(CXX) -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $< -o $@ $(CXXFLAGS)
-
- all: $(TARGET)
-
-@@ -8,10 +8,10 @@
- # http://www.trilithium.com/johan/2005/06/static-libstdc/
+ $(RM) $(OFILES)
+diff -ru powder113_src.orig/make/makerules.LINUX powder113_src/make/makerules.LINUX
+--- powder113_src.orig/make/makerules.LINUX 2009-01-18 19:54:09.000000000 -0500
++++ powder113_src/make/makerules.LINUX 2010-05-03 20:39:11.022462202 -0400
+@@ -13,8 +13,8 @@
# and is to try and ensure we end up with a static link
# of stdc++.
-- rm -f libstdc++.a
-+ $(RM) libstdc++.a
- ln -s `g++ -print-file-name=libstdc++.a`
-- g++ -O3 -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
-+ $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
+ $(RM) libstdc++.a
+- ln -s `g++ -print-file-name=libstdc++.a`
+- $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++ ln -s `$(CXX) -print-file-name=libstdc++.a`
++ $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS) $(LDFLAGS)
clean:
-- rm -f *.o
-- rm -f $(TARGET)
-+ $(RM) *.o
-+ $(RM) $(TARGET)
---- powder110_src/port/linux/Makefile.orig 2008-01-14 04:28:15.000000000 +0200
-+++ powder110_src/port/linux/Makefile 2009-01-29 02:19:52.018078431 +0200
-@@ -38,19 +38,54 @@
- ../../gfx/all_bitmaps.o \
- ../../rooms/allrooms.o
+ $(RM) $(OFILES)
+diff -ru powder113_src.orig/port/linux/Makefile powder113_src/port/linux/Makefile
+--- powder113_src.orig/port/linux/Makefile 2009-05-13 19:32:42.000000000 -0400
++++ powder113_src/port/linux/Makefile 2010-05-03 20:40:57.629463531 -0400
+@@ -48,7 +48,7 @@
+ all: $(TARGET)
--include ../../make/makerules.LINUX
-+PREMAKE_TRG = ../../support/map2c/map2c \
-+ ../../support/tile2c/tile2c \
-+ ../../support/bmp2c/bmp2c \
-+ ../../support/encyclopedia2c/encyclopedia2c \
-+ ../../support/enummaker/enummaker\
-+ ../../support/txt2c/txt2c
+ powder: premake $(OFILES)
+- $(CXX) -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++ $(CXX) -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS) $(LDFLAGS)
--clean:
-- cd ../.. ; rm -f *.o
-- cd ../../gfx ; rm -f *.o
-- rm -f *.o
-- cd ../sdl ; rm -f *.o
-- rm -f $(TARGET)
-+all: $(TARGET)
-+
-+
-+$(PREMAKE_TRG):
-+ $(MAKE) -C `dirname $@`
+ .cpp.o:
+ $(CXX) -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $< -o $@ $(CXXFLAGS)
+@@ -60,7 +60,7 @@
+ # of stdc++.
+ $(RM) libstdc++.a
+ ln -s `g++ -print-file-name=libstdc++.a`
+- $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++ $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS) $(LDFLAGS)
--premake:
-+premake: $(PREMAKE_TRG)
- cd ../../rooms ; ./buildrooms.bash
- cd ../../gfx ; ./rebuild.sh
- cd ../.. ; support/enummaker/enummaker source.txt
- cd ../.. ; support/txt2c/txt2c LICENSE.TXT license.cpp
- cd ../.. ; support/txt2c/txt2c CREDITS.TXT credits.cpp
- cd ../.. ; support/encyclopedia2c/encyclopedia2c encyclopedia.txt
-+
-+$(OFILES): premake
-+ $(CXX) -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $(patsubst %.o,%.cpp,$@) -o $@ $(CXXFLAGS)
-+
-+$(TARGET): $(OFILES)
-+ $(CXX) -o $@ $(OFILES) `sdl-config --libs` $(CXXFLAGS)
-+
-+$(TARGET)-static: $(OFILES)
-+ # This extra step is from:
-+ # http://www.trilithium.com/johan/2005/06/static-libstdc/
-+ # and is to try and ensure we end up with a static link
-+ # of stdc++.
-+ $(RM) libstdc++.a
-+ ln -s `g++ -print-file-name=libstdc++.a`
-+ $(CXX) -static-libgcc -L. -o $@ $(OFILES) `sdl-config --libs` $(CXXFLAGS)
-+
-+clean:
-+ $(RM) *.o $(TARGET) libstdc++.a
-+ cd ../../; $(RM) credits.cpp encyclopedia.cpp encyclopedia.h glbdef.cpp glbdef.h license.cpp
-+ cd ../../gfx; $(RM)
-+ cd ../../gfx; $(RM) icon_sdl.bmp.c slug_and_blood.bmp.c slug_and_blood_hires.bmp.c classic/*.c adambolt/*.c nethack/*.c ascii/*.c akoimeexx/*.c
-+ cd ../../rooms/; $(RM) *.cpp allrooms.h allrooms.o
-+ $(RM)
-+ $(RM) ../../*.o
-+ $(RM) ../../gfx/*.o
-+ $(RM) ../sdl/*.o
-+ @for trgt in $$( echo "$(PREMAKE_TRG)" | tr -s ' ' '\n' ); do \
-+ $(MAKE) clean -C `dirname $$trgt` ; \
-+ done;
-+
-+.PHONY: all clean premake
+ clean:
+ $(RM) $(OFILES)
diff --git a/games-roguelike/powder/powder-113.ebuild b/games-roguelike/powder/powder-113.ebuild
index 7e126ef50a75..bc292db0979b 100644
--- a/games-roguelike/powder/powder-113.ebuild
+++ b/games-roguelike/powder/powder-113.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/powder-113.ebuild,v 1.1 2010/05/03 23:56:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/powder-113.ebuild,v 1.2 2010/05/04 00:57:02 mr_bones_ Exp $
EAPI=2
inherit flag-o-matic eutils games
@@ -20,6 +20,8 @@ DEPEND="media-libs/libsdl[video]"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-make.patch )
+
src_compile() {
append-cxxflags -DCHANGE_WORK_DIRECTORY
emake -j1 -C port/linux || die