summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-29 18:15:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-29 18:15:03 +0000
commit2a631497e9b81e83d831e14db5ca0ff6b890bac3 (patch)
treec2d3470999c0178ac519f9fc170886dad4f1bd75 /games-roguelike
parentAdd games-roguelike/scourge:editor (diff)
downloadgentoo-2-2a631497e9b81e83d831e14db5ca0ff6b890bac3.tar.gz
gentoo-2-2a631497e9b81e83d831e14db5ca0ff6b890bac3.tar.bz2
gentoo-2-2a631497e9b81e83d831e14db5ca0ff6b890bac3.zip
Version bump, bug #144411
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/ChangeLog7
-rw-r--r--games-roguelike/scourge/files/digest-scourge-0.153
-rw-r--r--games-roguelike/scourge/scourge-0.15.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index ca5ad9053582..d9ef55c9b046 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/scourge
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.19 2006/06/13 16:32:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.20 2006/09/29 18:15:03 nyhm Exp $
+
+*scourge-0.15 (29 Sep 2006)
+
+ 29 Sep 2006; Tristan Heaven <nyhm@gentoo.org> +scourge-0.15.ebuild:
+ Version bump, bug #144411
*scourge-0.14 (13 Jun 2006)
diff --git a/games-roguelike/scourge/files/digest-scourge-0.15 b/games-roguelike/scourge/files/digest-scourge-0.15
new file mode 100644
index 000000000000..9b9e30ee7433
--- /dev/null
+++ b/games-roguelike/scourge/files/digest-scourge-0.15
@@ -0,0 +1,3 @@
+MD5 026b91d015865455a3dde7643ae74098 scourge-0.15.tar.gz 67139899
+RMD160 f8146df4dccfd9ab0d45f8f67dc668e7bc26cd46 scourge-0.15.tar.gz 67139899
+SHA256 ddc39417662a03ff90de7294c1479746039489e32ad58dd44520aecf1a7ea275 scourge-0.15.tar.gz 67139899
diff --git a/games-roguelike/scourge/scourge-0.15.ebuild b/games-roguelike/scourge/scourge-0.15.ebuild
new file mode 100644
index 000000000000..c8eb052fbaa5
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.15.ebuild,v 1.1 2006/09/29 18:15:03 nyhm Exp $
+
+inherit eutils wxwidgets games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="editor"
+
+DEPEND="x11-libs/libXmu
+ x11-libs/libXi
+ virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-net
+ media-libs/sdl-mixer
+ editor? ( >=x11-libs/wxGTK-2.6 )"
+
+S=${WORKDIR}/${P}/${PN}
+
+pkg_setup() {
+ games_pkg_setup
+ if use editor ; then
+ WX_GTK_VER="2.6" need-wxwidgets gtk2 \
+ || die "You need to emerge wxGTK with USE='X'"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use editor ; then
+ sed -i \
+ -e "/WXWIDGET_CFLAGS/s:wx-config:${WX_CONFIG}:" \
+ -e "/WXWIDGET_LIBS/s:wx-config:${WX_CONFIG}:" \
+ configure || die "sed failed"
+ fi
+}
+
+src_compile() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}/${PN}" \
+ $(use_enable editor) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use editor && mv "${D}/${GAMES_BINDIR}"/{tools,${PN}-tools}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ../scourge_data/* || die "doins failed"
+ doicon assets/scourge.png
+ make_desktop_entry scourge Scourge
+ dodoc AUTHORS README
+ prepgamesdirs
+}