summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-23 00:20:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-23 00:20:40 +0000
commit149c5ef916362c0ace95841757164cad7df1fc55 (patch)
tree5006186fb699e9b3c391502145f7ac8d3e470a30 /games-roguelike
parentFixed references to the WORKDIR in installed files (bug #95429). (diff)
downloadgentoo-2-149c5ef916362c0ace95841757164cad7df1fc55.tar.gz
gentoo-2-149c5ef916362c0ace95841757164cad7df1fc55.tar.bz2
gentoo-2-149c5ef916362c0ace95841757164cad7df1fc55.zip
Add patch from David Leverton to fix build on amd64 (bug #96814)
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/ChangeLog6
-rw-r--r--games-roguelike/scourge/files/0.10-64bit.patch9
-rw-r--r--games-roguelike/scourge/scourge-0.10.ebuild11
3 files changed, 18 insertions, 8 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index 133d5a665b91..ae826eef0570 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/scourge
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.10 2005/06/22 17:14:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.11 2005/06/23 00:20:40 mr_bones_ Exp $
+
+ 23 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.10-64bit.patch, scourge-0.10.ebuild:
+ Add patch from David Leverton to fix build on amd64 (bug #96814)
*scourge-0.10 (22 Jun 2005)
diff --git a/games-roguelike/scourge/files/0.10-64bit.patch b/games-roguelike/scourge/files/0.10-64bit.patch
new file mode 100644
index 000000000000..1fa565081b81
--- /dev/null
+++ b/games-roguelike/scourge/files/0.10-64bit.patch
@@ -0,0 +1,9 @@
+--- scourge/src/effect.cpp~ 2005-05-19 19:47:29.000000000 +0100
++++ scourge/src/effect.cpp 2005-06-22 23:30:02.000000000 +0100
+@@ -520,7 +520,7 @@
+ //float d = (float)(shape->getDepth() / GLShape::DIV) / 2.0;
+ h = (float)(shape->getHeight() / GLShape::DIV) / 3.0f;
+ if(h == 0) h = 0.25 / GLShape::DIV;
+- sh = ((float)( abs( particle->z - particle->startZ ) / GLShape::DIV) / 3.0f);
++ sh = ((float)( abs((int)(particle->z - particle->startZ)) / GLShape::DIV) / 3.0f);
+ if(h == 0) h = 0.25 / GLShape::DIV;
diff --git a/games-roguelike/scourge/scourge-0.10.ebuild b/games-roguelike/scourge/scourge-0.10.ebuild
index e8851cc0ffa0..fbc7743ae956 100644
--- a/games-roguelike/scourge/scourge-0.10.ebuild
+++ b/games-roguelike/scourge/scourge-0.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.10.ebuild,v 1.1 2005/06/22 17:14:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.10.ebuild,v 1.2 2005/06/23 00:20:40 mr_bones_ Exp $
-inherit games
+inherit flag-o-matic eutils games
DESCRIPTION="A rogue-like adventure game to eliminate pests"
HOMEPAGE="http://scourge.sf.net"
@@ -26,14 +26,11 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
find "${S}/data" -type f -exec chmod a-x \{\} \;
- cd "${S}"
- sed -i \
- -e "s:rootDir = (char\*)BR_DATADIR( \"/data\" ):rootDir=DATA_DIR:" \
- src/main.cpp \
- || die "sed failed"
+ epatch "${FILESDIR}/${PV}-64bit.patch"
}
src_compile() {
+ append-flags -DENABLE_BINRELOC -DBR_PTHREADS=0
egamesconf \
--with-data-dir="${GAMES_DATADIR}/${PN}/data" \
|| die