summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-04-27 07:40:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-04-27 07:40:06 +0000
commit802ee810590eba2e745fc1ee88c1aafaadb27a15 (patch)
tree2a2f166025ee3d2c9850bc78ec3cd20deebc0d05 /games-roguelike/tome
parentold (diff)
downloadgentoo-2-802ee810590eba2e745fc1ee88c1aafaadb27a15.tar.gz
gentoo-2-802ee810590eba2e745fc1ee88c1aafaadb27a15.tar.bz2
gentoo-2-802ee810590eba2e745fc1ee88c1aafaadb27a15.zip
old
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-roguelike/tome')
-rw-r--r--games-roguelike/tome/files/2.3.3-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/files/digest-tome-2.3.33
-rw-r--r--games-roguelike/tome/files/tome-2.3.3-gcc41.patch18
-rw-r--r--games-roguelike/tome/tome-2.3.3.ebuild124
4 files changed, 0 insertions, 176 deletions
diff --git a/games-roguelike/tome/files/2.3.3-gentoo-paths.patch b/games-roguelike/tome/files/2.3.3-gentoo-paths.patch
deleted file mode 100644
index d171a1cf540f..000000000000
--- a/games-roguelike/tome/files/2.3.3-gentoo-paths.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
---- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
-+++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
-@@ -5670,3 +5670,3 @@
- /* Build the filename */
-- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
-+ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
-
-@@ -5748,3 +5748,3 @@
- /* Build the filename */
-- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
-+ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
-
-@@ -5846,3 +5846,3 @@
- /* Build the filename */
-- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
-+ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
-
-@@ -6296,3 +6296,3 @@
- /* Build the filename */
-- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
-+ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
-
-diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
---- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
-+++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
-@@ -6686,3 +6686,3 @@
- /* Build the filename */
-- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
-+ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
-
diff --git a/games-roguelike/tome/files/digest-tome-2.3.3 b/games-roguelike/tome/files/digest-tome-2.3.3
deleted file mode 100644
index 66b3afd6615a..000000000000
--- a/games-roguelike/tome/files/digest-tome-2.3.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d6df22607dd1009ab96bd3e6d6acf729 tome-233-src.tar.bz2 2865537
-RMD160 5f7006182be65e1fd49a9f3be1ef1f25e00fd0d3 tome-233-src.tar.bz2 2865537
-SHA256 2220419d69533ac8c3cc5687c1f9f6e5c9eadacf9643900ba50dce3696a9d721 tome-233-src.tar.bz2 2865537
diff --git a/games-roguelike/tome/files/tome-2.3.3-gcc41.patch b/games-roguelike/tome/files/tome-2.3.3-gcc41.patch
deleted file mode 100644
index 89ef0bb2e07d..000000000000
--- a/games-roguelike/tome/files/tome-2.3.3-gcc41.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/main-gtk.c.old 2006-10-08 22:36:50.000000000 +0200
-+++ src/main-gtk.c 2006-10-08 22:37:24.000000000 +0200
-@@ -4478,13 +4478,13 @@
- strnfmt(buf, 64, "/Terms/%s", angband_term_name[i]);
-
- /* XXX XXX Store it in the menu definition */
-- (cptr)term_entry[i].path = string_make(buf);
-+ term_entry[i].path = string_make(buf);
-
- /* XXX XXX Build the real path name to the entry */
- strnfmt(buf, 64, "/Options/Font/%s", angband_term_name[i]);
-
- /* XXX XXX Store it in the menu definition */
-- (cptr)font_entry[i].path = string_make(buf);
-+ font_entry[i].path = string_make(buf);
- }
- }
-
diff --git a/games-roguelike/tome/tome-2.3.3.ebuild b/games-roguelike/tome/tome-2.3.3.ebuild
deleted file mode 100644
index 7c54a07f30e8..000000000000
--- a/games-roguelike/tome/tome-2.3.3.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.3.3.ebuild,v 1.5 2007/03/12 17:19:44 genone Exp $
-
-inherit eutils flag-o-matic games
-
-MY_PV=${PV//./}
-DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
-HOMEPAGE="http://t-o-m-e.net/"
-SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
-
-LICENSE="Moria"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
-IUSE="X Xaw3d gtk sdl"
-
-RDEPEND=">=sys-libs/ncurses-5
- X? ( x11-libs/libX11 )
- Xaw3d? ( x11-libs/libXaw )
- sdl? (
- media-libs/sdl-ttf
- media-libs/sdl-image
- media-libs/libsdl )
- gtk? ( !amd64? ( =x11-libs/gtk+-1.2* ) )"
-DEPEND="${REDEPEND}
- x11-misc/makedepend"
-
-S="${WORKDIR}/tome-${MY_PV}-src"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc41.patch
- cd "src"
- mv makefile.std makefile
- epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
- sed -i \
- -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
- || die "sed failed"
-
- find "${S}" -name .cvsignore -exec rm -f \{\} \;
- find "${S}/lib/edit" -type f -exec chmod a-x \{\} \;
-}
-
-src_compile() {
- local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="-lncurses"
- if use sdl || use X || use gtk || use Xaw3d; then
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
- -DSUPPORT_GAMMA"
- fi
- if use sdl || use X || use Xaw3d; then
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
- fi
- if use sdl; then
- GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
- GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
- fi
- if use X; then
- GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
- GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
- fi
- if use Xaw3d; then
- GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
- GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
- fi
- if use gtk; then
- if use amd64; then
- einfo "gtk support will not be built for amd64"
- else
- GENTOO_INCLUDES="${GENTOO_INCLUDES} $(gtk-config --cflags)"
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK "
- GENTOO_LIBS="${GENTOO_LIBS} $(gtk-config --libs) "
- fi
- fi
- GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
- GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
- append-ldflags $(bindnow-flags)
- cd src
- make \
- INCLUDES="${GENTOO_INCLUDES}" \
- DEFINES="${GENTOO_DEFINES}" \
- depend || die "make depend failed"
- emake ./tolua || die "emake ./tolua failed"
- emake \
- COPTS="${CFLAGS}" \
- INCLUDES="${GENTOO_INCLUDES}" \
- DEFINES="${GENTOO_DEFINES}" \
- LIBS="${GENTOO_LIBS}" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" \
- || die "emake failed"
-}
-
-src_install() {
- cd src
- make \
- DESTDIR="${D}" \
- OWNER="${GAMES_USER}" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" install \
- || die "make install failed"
- cd "${S}"
- dodoc *.txt
-
- dodir "${GAMES_STATEDIR}"
- touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
- prepgamesdirs
- fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
- #FIXME: something has to be done about this.
- fperms g+w "${GAMES_DATADIR}/${PN}/data"
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
- echo
- elog "If you have older save files and you wish to continue those games,"
- elog "you'll need to remerge the version of ToME with which you started"
- elog "those save-games."
-}