summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-01-28 16:07:52 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-01-28 16:07:52 +0000
commite572b1d5e4e34088e6458d044da09cd4673bae6b (patch)
tree5b37d1417b415c556c42bcc54845c4e2a8cc0aa3 /games-roguelike/scourge/scourge-0.8.ebuild
parentVersion bump and CFLAGS fixes. (diff)
downloadgentoo-2-e572b1d5e4e34088e6458d044da09cd4673bae6b.tar.gz
gentoo-2-e572b1d5e4e34088e6458d044da09cd4673bae6b.tar.bz2
gentoo-2-e572b1d5e4e34088e6458d044da09cd4673bae6b.zip
Version bumped to 0.8 and closing bug #76891.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-roguelike/scourge/scourge-0.8.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-roguelike/scourge/scourge-0.8.ebuild b/games-roguelike/scourge/scourge-0.8.ebuild
new file mode 100644
index 000000000000..9ff9b14a0814
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.8.ebuild,v 1.1 2005/01/28 16:07:52 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-net
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/src"
+ find "${S}" -name .DS_Store -exec rm -f \{\} \;
+ find "${S}/data" -type f -exec chmod a-x \{\} \;
+}
+
+src_compile() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc AUTHORS README || die "dodoc failed"
+ prepgamesdirs
+}