summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-20 21:35:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-20 21:35:07 +0000
commitfdd181a377dbcafc4cc9ab4a85050a0af21323d1 (patch)
treec7ac892f95552a5f7c3ef863c1b492a0f096d776 /games-roguelike/fargoal
parentMarked stable x86 (Manifest recommit) (diff)
downloadgentoo-2-fdd181a377dbcafc4cc9ab4a85050a0af21323d1.tar.gz
gentoo-2-fdd181a377dbcafc4cc9ab4a85050a0af21323d1.tar.bz2
gentoo-2-fdd181a377dbcafc4cc9ab4a85050a0af21323d1.zip
tidy
Diffstat (limited to 'games-roguelike/fargoal')
-rw-r--r--games-roguelike/fargoal/fargoal-20030731b.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/games-roguelike/fargoal/fargoal-20030731b.ebuild b/games-roguelike/fargoal/fargoal-20030731b.ebuild
index 4d3f93c97791..297667d2691e 100644
--- a/games-roguelike/fargoal/fargoal-20030731b.ebuild
+++ b/games-roguelike/fargoal/fargoal-20030731b.ebuild
@@ -1,35 +1,36 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/fargoal/fargoal-20030731b.ebuild,v 1.3 2004/06/24 23:12:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/fargoal/fargoal-20030731b.ebuild,v 1.4 2004/08/20 21:35:07 mr_bones_ Exp $
inherit eutils games
-S="${WORKDIR}/${PN}"
DESCRIPTION="The Sword of Fargoal - a remake of C64's old dungeon crawler game"
HOMEPAGE="http://squidfighter.sourceforge.net/fargoal/"
SRC_URI="mirror://sourceforge/squidfighter/${PN}${PV}.zip"
-KEYWORDS="x86 ~ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ~ppc"
IUSE=""
RDEPEND="media-libs/allegro"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}/${PN}"
+
src_unpack() {
unpack ${A}
cd ${S}/src
epatch "${FILESDIR}/gentoo-home-write.patch"
sed -i \
-e "s/^\(C\(XX\)\?FLAGS =\).*/\1 ${CFLAGS} /g" Makefile \
- || die "sed Makefile failed"
+ || die "sed Makefile failed"
sed -i \
-e "s:sfx/:/${GAMES_DATADIR}/${PN}/sfx/:g" \
-e "s:gfx/:/${GAMES_DATADIR}/${PN}/gfx/:g" \
-e "s:data/:${GAMES_DATADIR}/${PN}/data/:g" {*,../data/sof.cfg} \
- || die "sed failed"
+ || die "sed failed"
}
src_compile() {
@@ -40,10 +41,9 @@ src_compile() {
src_install() {
# install as fargoal instead of sword since that may conflict with
# other packages.
- newgamesbin sword fargoal || die "newgamesbin failed"
- dodir "${GAMES_DATADIR}/${PN}" || die "dodir failed"
- cp -r {data,gfx,sfx} ${D}/${GAMES_DATADIR}/${PN} \
- || die "cp failed"
- dohtml readme.html || die "dohtml failed"
+ newgamesbin sword fargoal || die "newgamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r {data,gfx,sfx} ${D}/${GAMES_DATADIR}/${PN} || die "cp failed"
+ dohtml readme.html
prepgamesdirs
}