summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-30 21:43:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-30 21:43:51 +0000
commit922be553b49b498d7a655d4dd54b724003823518 (patch)
treef6c5bbaf19d952067aa8e02a9aa7596c65788a9c /games-roguelike/crossfire-client
parentVersion bump. (diff)
downloadgentoo-2-922be553b49b498d7a655d4dd54b724003823518.tar.gz
gentoo-2-922be553b49b498d7a655d4dd54b724003823518.tar.bz2
gentoo-2-922be553b49b498d7a655d4dd54b724003823518.zip
version bump (bug #410219)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog8
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 59559e7f24c4..77b511754d07 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.28 2012/05/02 21:06:17 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.29 2012/07/30 21:43:51 mr_bones_ Exp $
+
+*crossfire-client-1.70.0 (30 Jul 2012)
+
+ 30 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-client-1.70.0.ebuild:
+ version bump (bug #410219)
02 May 2012; Jeff Horelick <jdhore@gentoo.org>
crossfire-client-1.12.0.ebuild:
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
new file mode 100644
index 000000000000..0aa6b5112d6d
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild,v 1.1 2012/07/30 21:43:51 mr_bones_ Exp $
+
+EAPI=2
+inherit gnome2-utils games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa lua oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ virtual/opengl
+ x11-libs/gtk+:2
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image )
+ lua? ( dev-lang/lua )
+ net-misc/curl
+ media-libs/freeglut
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf="--disable-dependency-tracking"
+
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa9 --disable-alsa"
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src || die
+ fi
+ emake || die
+}
+
+src_install() {
+ local s
+
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}