summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-31 19:08:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-31 19:08:16 +0000
commitf4f8a22ca65218b97cbdf34f3398c4bdf6d4b4ac (patch)
tree127d9be34015866c1bc88b611841b3fd81d0100b /games-puzzle
parentVersion bumped. Fixed hardcoded rubydir, closing bug #46237 (Manifest recommit) (diff)
downloadgentoo-2-f4f8a22ca65218b97cbdf34f3398c4bdf6d4b4ac.tar.gz
gentoo-2-f4f8a22ca65218b97cbdf34f3398c4bdf6d4b4ac.tar.bz2
gentoo-2-f4f8a22ca65218b97cbdf34f3398c4bdf6d4b4ac.zip
flag-o-matic; error check sed; tidy
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gemhun/ChangeLog7
-rw-r--r--games-puzzle/gemhun/gemhun-20031016.ebuild23
2 files changed, 19 insertions, 11 deletions
diff --git a/games-puzzle/gemhun/ChangeLog b/games-puzzle/gemhun/ChangeLog
index cb18e5d6f833..0b57abdc02ee 100644
--- a/games-puzzle/gemhun/ChangeLog
+++ b/games-puzzle/gemhun/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/gemhun
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/ChangeLog,v 1.1 2003/11/08 17:13:04 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/ChangeLog,v 1.2 2004/03/31 19:04:33 mr_bones_ Exp $
+
+ 31 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> gemhun-20031016.ebuild:
+ flag-o-matic; error check sed; tidy
*gemhun-20031016 (08 Nov 2003)
diff --git a/games-puzzle/gemhun/gemhun-20031016.ebuild b/games-puzzle/gemhun/gemhun-20031016.ebuild
index 74ef4a3043da..ca25fa08892c 100644
--- a/games-puzzle/gemhun/gemhun-20031016.ebuild
+++ b/games-puzzle/gemhun/gemhun-20031016.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/gemhun-20031016.ebuild,v 1.2 2004/02/03 21:30:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/gemhun-20031016.ebuild,v 1.3 2004/03/31 19:04:33 mr_bones_ Exp $
-inherit eutils games
+inherit eutils flag-o-matic games
S="${WORKDIR}/GemHunters"
DESCRIPTION="A puzzle game about grouping gems of a chosen amount together"
@@ -14,16 +14,20 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-DEPEND="dev-games/kyra
+RDEPEND="dev-games/kyra
>=media-libs/sdl-mixer-1.2.1
virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-gentoo-paths.patch
append-flags -DGENTOO_DATADIR="'\"${GAMES_DATADIR}/${PN}/\"'"
- sed -i "s:-O3:${CFLAGS}:" src/makefile.unix
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" src/makefile.unix \
+ || die "sed src/makefile.unix failed"
}
src_compile() {
@@ -32,11 +36,12 @@ src_compile() {
}
src_install() {
- dogamesbin unix/*/gemhun
- local datadir=${GAMES_DATADIR}/${PN}
- dodir ${datadir}
- cp -r data/* ${D}/${datadir}/
- find ${D}/${datadir} -name makefile -exec rm '{}' \;
+ local datadir="${GAMES_DATADIR}/${PN}"
+
+ dogamesbin unix/*/gemhun || die "dogamesbin failed"
+ dodir "${datadir}"
+ cp -r data/* "${D}/${datadir}/" || die "cp failed"
+ find "${D}/${datadir}" -name makefile -exec rm '{}' \;
dodoc changelog readme todo
prepgamesdirs
}