summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 19:33:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 19:33:35 +0000
commite98f6f163f95ae0fcf77012cc02ec050669d3383 (patch)
treeb26b587d81cad6a4b39f0fedc0363823cc0f7c58 /games-puzzle
parenttidy (diff)
downloadgentoo-2-e98f6f163f95ae0fcf77012cc02ec050669d3383.tar.gz
gentoo-2-e98f6f163f95ae0fcf77012cc02ec050669d3383.tar.bz2
gentoo-2-e98f6f163f95ae0fcf77012cc02ec050669d3383.zip
version bump (bug #298798) with ebuild submission from Samuli Suominen
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/cuyo/ChangeLog11
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1.ebuild51
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch12
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch32
-rw-r--r--games-puzzle/cuyo/metadata.xml3
5 files changed, 107 insertions, 2 deletions
diff --git a/games-puzzle/cuyo/ChangeLog b/games-puzzle/cuyo/ChangeLog
index 798b297d2781..a570116930a0 100644
--- a/games-puzzle/cuyo/ChangeLog
+++ b/games-puzzle/cuyo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/cuyo
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.19 2009/02/17 00:02:31 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.20 2009/12/30 19:33:35 mr_bones_ Exp $
+
+*cuyo-2.1.1 (30 Dec 2009)
+
+ 30 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org> +cuyo-2.1.1.ebuild,
+ +files/cuyo-2.1.1-gcc44.patch, +files/cuyo-2.1.1-gentoo.patch,
+ metadata.xml:
+ version bump (bug #298798) with ebuild submission from Samuli Suominen
17 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> cuyo-1.8.6.ebuild:
EAPI=2; add desktop entry (bug #259237)
diff --git a/games-puzzle/cuyo/cuyo-2.1.1.ebuild b/games-puzzle/cuyo/cuyo-2.1.1.ebuild
new file mode 100644
index 000000000000..420f80f92018
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-2.1.1.ebuild,v 1.1 2009/12/30 19:33:35 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools gnome2-utils versionator games
+
+MY_P=${PN}-$(get_version_component_range 1).~-$(get_version_component_range 2-3)
+DESCRIPTION="highly addictive and remotely related to tetris"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+SRC_URI="http://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+music"
+
+DEPEND="sys-libs/zlib
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer
+ music? ( media-libs/sdl-mixer[mikmod] )
+ media-libs/sdl-image"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
new file mode 100644
index 000000000000..60ed1fffaf2f
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur cuyo-2.~-1.1.orig/src/stringzeug.h cuyo-2.~-1.1/src/stringzeug.h
+--- cuyo-2.~-1.1.orig/src/stringzeug.h 2006-07-03 20:26:23.000000000 +0300
++++ cuyo-2.~-1.1/src/stringzeug.h 2009-12-29 16:17:18.000000000 +0200
+@@ -20,7 +20,7 @@
+
+ #include <config.h>
+ #include <string>
+-
++#include <stdio.h>
+
+
+
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..38b8c4224463
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
@@ -0,0 +1,32 @@
+diff -ru cuyo-2.~-1.1.orig/icons/Makefile.am cuyo-2.~-1.1/icons/Makefile.am
+--- cuyo-2.~-1.1.orig/icons/Makefile.am 2007-12-20 12:22:32.000000000 -0500
++++ cuyo-2.~-1.1/icons/Makefile.am 2009-12-30 13:44:39.111042770 -0500
+@@ -1,4 +1,4 @@
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = cuyo.desktop
+
+
+@@ -25,7 +25,7 @@
+ # Das vorige war falsch: die png sollen alle cuyo.png heissen
+ # und nicht cuyo-xxxx.png. Deshalb nachfolgend neue Version:
+
+-iconsdir = $(datadir)/icons/hicolor
++iconsdir = /usr/share/icons/hicolor
+ icons_DATA = cuyo-32x32.png cuyo-64x64.png
+
+ install-iconsDATA:
+diff -ru cuyo-2.~-1.1.orig/icons/cuyo.desktop cuyo-2.~-1.1/icons/cuyo.desktop
+--- cuyo-2.~-1.1.orig/icons/cuyo.desktop 2007-12-20 12:22:32.000000000 -0500
++++ cuyo-2.~-1.1/icons/cuyo.desktop 2009-12-30 13:45:15.823781932 -0500
+@@ -3,9 +3,8 @@
+ Icon=cuyo
+ Type=Application
+ Terminal=false
+-MimeType=application/x-executable
++MimeType=application/x-executable;
+ Categories=Game;BlocksGame;
+-Encoding=UTF-8
+ Comment=A tetris like game with many levels
+ Comment[de]=Ein Tetris-artiges Spiel mit vielen Leveln
+ Exec=cuyo
diff --git a/games-puzzle/cuyo/metadata.xml b/games-puzzle/cuyo/metadata.xml
index d3c2cc926f0b..658a1ecd0c6d 100644
--- a/games-puzzle/cuyo/metadata.xml
+++ b/games-puzzle/cuyo/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+<use>
+ <flag name="music">Enable playing of background music</flag>
+</use>
</pkgmetadata>