summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-10 07:36:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-10 07:36:08 +0000
commitd2cc5538b78559276aa9025b505f385935adf7a4 (patch)
treeb11576911c6b3a1c47ef07d77b3b20b64c528ff7 /games-puzzle
parentRun ck-launch-session again to restore functionality with Thunar disk handlin... (diff)
downloadgentoo-2-d2cc5538b78559276aa9025b505f385935adf7a4.tar.gz
gentoo-2-d2cc5538b78559276aa9025b505f385935adf7a4.tar.bz2
gentoo-2-d2cc5538b78559276aa9025b505f385935adf7a4.zip
Respect LDFLAGS. Bug #336111
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ngstar/ChangeLog8
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch20
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild16
3 files changed, 34 insertions, 10 deletions
diff --git a/games-puzzle/ngstar/ChangeLog b/games-puzzle/ngstar/ChangeLog
index c225817d0bf5..439675a715a5 100644
--- a/games-puzzle/ngstar/ChangeLog
+++ b/games-puzzle/ngstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/ngstar
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.7 2008/05/02 19:44:34 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.8 2010/09/10 07:36:08 tupone Exp $
+
+ 10 Sep 2010; Tupone Alfredo <tupone@gentoo.org> ngstar-2.1.8-r2.ebuild,
+ +files/ngstar-2.1.8-ldflags.patch:
+ Respect LDFLAGS. Bug #336111 by flameeyes@gentoo.org
02 May 2008; Tristan Heaven <nyhm@gentoo.org>
+files/ngstar-2.1.8-gcc43.patch, ngstar-2.1.8-r2.ebuild:
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
new file mode 100644
index 000000000000..3c8dd8e8fad8
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
@@ -0,0 +1,20 @@
+--- src/Makefile.old 2010-09-10 09:22:06.000000000 +0200
++++ src/Makefile 2010-09-10 09:33:20.000000000 +0200
+@@ -56,8 +56,7 @@
+
+ $(BIN) : $(SOURCE) $(BIN_DEPS)
+ echo "Compiling $(BIN)"
+- $(CXX) $< $(BIN_DEPS) -o $@ $(CC_LIBS) $(CC_INCLUDES) $(CPPFLAGS)
+- strip -s $@
++ $(CXX) ${LDFLAGS} $< $(BIN_DEPS) -o $@ $(CC_LIBS) $(CC_INCLUDES) $(CPPFLAGS)
+ ifdef USE_FLTK2
+ -ln -s `basename $(BIN)` $(BIN_FLTK2)
+ endif
+@@ -68,7 +67,6 @@
+ $(BIN_STATIC) : $(SOURCE) $(BIN_DEPS)
+ echo "Compiling $(BIN)"
+ $(CXX) -static $< $(BIN_DEPS) -o $@ $(CC_LIBS_STATIC) $(CC_INCLUDES) $(CPPFLAGS)
+- strip -s $@
+ ifdef USE_FLTK2
+ -ln -s `basename $(BIN_STATIC)` $(BIN_STATIC_FLTK2)
+ endif
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
index ea49a8ec7691..f05d8b5164f4 100644
--- a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.5 2008/05/02 19:44:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.6 2010/09/10 07:36:08 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -16,25 +17,24 @@ IUSE=""
DEPEND="sys-libs/ncurses
sys-libs/gpm"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo-path.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \
-e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
-e "/^CPPFLAGS/s:+=:+= ${CXXFLAGS}:" \
+ -e "/SILENT/d" \
configure || die "sed configure failed"
sed -i '/strip/d' src/Makefile || die "sed makefile failed"
}
-src_compile() {
+src_configure() {
./configure \
--prefix "" \
--without-fltk2 || die "configure failed"
- emake || die "emake failed"
}
src_install() {