summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-25 14:51:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-25 14:51:27 +0000
commitc1b4ca78019b52b9d705ed6de39cafd33c406ba3 (patch)
tree39bfbe739bd2abd5c401b0b5dd26b0302546c7c6 /games-puzzle
parentAdd REE18 support (diff)
downloadgentoo-2-c1b4ca78019b52b9d705ed6de39cafd33c406ba3.tar.gz
gentoo-2-c1b4ca78019b52b9d705ed6de39cafd33c406ba3.tar.bz2
gentoo-2-c1b4ca78019b52b9d705ed6de39cafd33c406ba3.zip
version bump (bug #319527)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/zaz/ChangeLog8
-rw-r--r--games-puzzle/zaz/files/zaz-0.7.0-build.patch19
-rw-r--r--games-puzzle/zaz/zaz-0.7.0.ebuild47
3 files changed, 73 insertions, 1 deletions
diff --git a/games-puzzle/zaz/ChangeLog b/games-puzzle/zaz/ChangeLog
index 7d60d8a9fccf..9f93b2793cb5 100644
--- a/games-puzzle/zaz/ChangeLog
+++ b/games-puzzle/zaz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/zaz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.8 2010/05/23 19:47:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.9 2010/05/25 14:51:27 mr_bones_ Exp $
+
+*zaz-0.7.0 (25 May 2010)
+
+ 25 May 2010; Michael Sterrett <mr_bones_@gentoo.org> +zaz-0.7.0.ebuild,
+ +files/zaz-0.7.0-build.patch:
+ version bump (bug #319527)
23 May 2010; Pacho Ramos <pacho@gentoo.org> zaz-0.3.3.ebuild:
stable amd64, bug 311261
diff --git a/games-puzzle/zaz/files/zaz-0.7.0-build.patch b/games-puzzle/zaz/files/zaz-0.7.0-build.patch
new file mode 100644
index 000000000000..bef2954bf088
--- /dev/null
+++ b/games-puzzle/zaz/files/zaz-0.7.0-build.patch
@@ -0,0 +1,19 @@
+diff -ru zaz-0.7.0.orig/Makefile.am zaz-0.7.0/Makefile.am
+--- zaz-0.7.0.orig/Makefile.am 2009-10-14 18:20:14.000000000 -0400
++++ zaz-0.7.0/Makefile.am 2010-05-13 15:49:59.404464060 -0400
+@@ -2,15 +2,6 @@
+
+ SUBDIRS = po src data extra
+
+-dist_doc_DATA = \
+- README\
+- COPYING\
+- AUTHORS\
+- ChangeLog\
+- INSTALL\
+- NEWS
+-
+-
+ EXTRA_DIST = config.rpath m4/ChangeLog\
+ $(shared_data_DATA) \
+ zaz.anjuta\
diff --git a/games-puzzle/zaz/zaz-0.7.0.ebuild b/games-puzzle/zaz/zaz-0.7.0.ebuild
new file mode 100644
index 000000000000..ab5047fc8863
--- /dev/null
+++ b/games-puzzle/zaz/zaz-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-0.7.0.ebuild,v 1.1 2010/05/25 14:51:27 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="http://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,audio,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog
+ prepgamesdirs
+}