summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-07 17:58:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-07 17:58:32 +0000
commita76cf477ba2b725c481f4f76e2ac0dda6a1d27ff (patch)
tree049a086b0e4e10357653c2c2300d6fc97cf1adaf /games-puzzle
parentbumped dep versions to avoid erroneous gx86-multilib satisfaction by portage (diff)
downloadgentoo-2-a76cf477ba2b725c481f4f76e2ac0dda6a1d27ff.tar.gz
gentoo-2-a76cf477ba2b725c481f4f76e2ac0dda6a1d27ff.tar.bz2
gentoo-2-a76cf477ba2b725c481f4f76e2ac0dda6a1d27ff.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/amoebax/ChangeLog11
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.1.ebuild44
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch4
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch41
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch12
5 files changed, 108 insertions, 4 deletions
diff --git a/games-puzzle/amoebax/ChangeLog b/games-puzzle/amoebax/ChangeLog
index 969bf1c4e4d3..3917413c9f80 100644
--- a/games-puzzle/amoebax/ChangeLog
+++ b/games-puzzle/amoebax/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-puzzle/amoebax
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.9 2014/05/15 16:48:41 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.10 2014/07/07 17:58:32 mr_bones_ Exp $
+
+*amoebax-0.2.1 (07 Jul 2014)
+
+ 07 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> +amoebax-0.2.1.ebuild,
+ +files/amoebax-0.2.1-aclocal.patch, +files/amoebax-0.2.1-compile.patch,
+ files/amoebax-0.2.0-aclocal.patch, files/amoebax-0.2.0-gcc43.patch,
+ files/amoebax-0.2.0-glibc2.10.patch:
+ version bump
15 May 2014; Ulrich Müller <ulm@gentoo.org> amoebax-0.2.0.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
@@ -35,4 +43,3 @@
15 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+amoebax-0.2.0.ebuild:
initial commit
-
diff --git a/games-puzzle/amoebax/amoebax-0.2.1.ebuild b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
new file mode 100644
index 000000000000..0d728163e4ff
--- /dev/null
+++ b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.1.ebuild,v 1.1 2014/07/07 17:58:32 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="a cute and addictive action-puzzle game, similar to tetris"
+HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
+SRC_URI="http://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
+
+LICENSE="FreeArt GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-aclocal.patch \
+ "${FILESDIR}"/${P}-compile.patch
+
+ sed -i \
+ -e "/^SUBDIRS/s:doc ::" \
+ Makefile.am || die
+ sed -i \
+ -e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
+ -e "/^desktopdir/s:=.*:=/usr/share/applications:" \
+ data/Makefile.am || die
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s/.svg//' \
+ data/amoebax.desktop || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch b/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch
index 312585900309..4cafc8d44de8 100644
--- a/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch
+++ b/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch
@@ -1,5 +1,5 @@
---- m4/objc.m4.old 2010-01-09 19:41:58.000000000 +0100
-+++ m4/objc.m4 2010-01-09 19:43:35.000000000 +0100
+--- m4/objc.m4.old
++++ m4/objc.m4
@@ -448,32 +448,32 @@
# AC_LANG_SOURCE(Objective C)(BODY)
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
new file mode 100644
index 000000000000..4cafc8d44de8
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
@@ -0,0 +1,41 @@
+--- m4/objc.m4.old
++++ m4/objc.m4
+@@ -448,32 +448,32 @@
+
+ # AC_LANG_SOURCE(Objective C)(BODY)
+ # ---------------------------------
+-m4_copy([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
++m4_copy_force([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
+
+
+ # AC_LANG_PROGRAM(Objective C)([PROLOGUE], [BODY])
+ # ------------------------------------------------
+-m4_copy([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
++m4_copy_force([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
+
+
+ # AC_LANG_CALL(Objective C)(PROLOGUE, FUNCTION)
+ # ---------------------------------------------
+-m4_copy([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
++m4_copy_force([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
+
+
+ # AC_LANG_FUNC_LINK_TRY(Objective C)(FUNCTION)
+ # --------------------------------------------
+-m4_copy([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
++m4_copy_force([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
+
+
+ # AC_LANG_BOOL_COMPILE_TRY(Objective C)(PROLOGUE, EXPRESSION)
+ # -----------------------------------------------------------
+-m4_copy([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
++m4_copy_force([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
+
+
+ # AC_LANG_INT_SAVE(Objective C)(PROLOGUE, EXPRESSION)
+ # ---------------------------------------------------
+-m4_copy([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
++m4_copy_force([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
+
+
+
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
new file mode 100644
index 000000000000..79c66a8c95b8
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
@@ -0,0 +1,12 @@
+--- src/binreloc.cxx
++++ src/binreloc.cxx
+@@ -739,7 +739,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;