summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-02 09:29:36 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-02 09:29:36 +0000
commita0379a472f24781830cb0a2ebba5edda38a07549 (patch)
tree0bfa4500b60729503996756b4261a9329eb6854f /games-puzzle
parentDisable dev-lang/vala support because it's not ready to be stabilized wrt #34... (diff)
downloadgentoo-2-a0379a472f24781830cb0a2ebba5edda38a07549.tar.gz
gentoo-2-a0379a472f24781830cb0a2ebba5edda38a07549.tar.bz2
gentoo-2-a0379a472f24781830cb0a2ebba5edda38a07549.zip
Fix overflow. Bug #339702
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/toppler/ChangeLog8
-rw-r--r--games-puzzle/toppler/files/toppler-1.1.3-ovflfix.patch11
-rw-r--r--games-puzzle/toppler/toppler-1.1.3.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/games-puzzle/toppler/ChangeLog b/games-puzzle/toppler/ChangeLog
index 36853a4e26fe..97b588be1ab4 100644
--- a/games-puzzle/toppler/ChangeLog
+++ b/games-puzzle/toppler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/toppler
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/ChangeLog,v 1.19 2009/02/06 22:31:48 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/ChangeLog,v 1.20 2010/11/02 09:29:35 tupone Exp $
+
+ 02 Nov 2010; Tupone Alfredo <tupone@gentoo.org> toppler-1.1.3.ebuild,
+ +files/toppler-1.1.3-ovflfix.patch:
+ Fix overflow. Bug #339702 by flameeyes@gentoo.org
06 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+files/toppler-1.1.3-gentoo.patch, toppler-1.1.3.ebuild:
diff --git a/games-puzzle/toppler/files/toppler-1.1.3-ovflfix.patch b/games-puzzle/toppler/files/toppler-1.1.3-ovflfix.patch
new file mode 100644
index 000000000000..2821917b99d5
--- /dev/null
+++ b/games-puzzle/toppler/files/toppler-1.1.3-ovflfix.patch
@@ -0,0 +1,11 @@
+--- leveledit.cc.old 2010-11-02 09:33:24.000000000 +0100
++++ leveledit.cc 2010-11-02 10:12:11.000000000 +0100
+@@ -436,7 +436,7 @@
+
+ snprintf(knam, 256, "%s%s", keymod2str(_ed_keys[k].mod), SDL_GetKeyName(_ed_keys[k].key));
+
+- snprintf(tabbuf2, 256, "%3i", maxkeylen - scr_textlength(knam));
++ snprintf(tabbuf2, sizeof(tabbuf2), "%3i", maxkeylen - scr_textlength(knam));
+ if (tabbuf2[0] < '0') tabbuf2[0] = '0';
+ if (tabbuf2[1] < '0') tabbuf2[1] = '0';
+ if (tabbuf2[2] < '0') tabbuf2[2] = '0';
diff --git a/games-puzzle/toppler/toppler-1.1.3.ebuild b/games-puzzle/toppler/toppler-1.1.3.ebuild
index 2f2710d305e9..23373db981dc 100644
--- a/games-puzzle/toppler/toppler-1.1.3.ebuild
+++ b/games-puzzle/toppler/toppler-1.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.3.ebuild,v 1.5 2009/02/06 22:31:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.3.ebuild,v 1.6 2010/11/02 09:29:35 tupone Exp $
EAPI=2
inherit games
@@ -21,7 +21,8 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
S=${WORKDIR}/${P/a/}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ovflfix.patch )
src_configure() {
egamesconf $(use_enable nls)