summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-29 17:09:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-29 17:09:46 +0000
commit9cdb7326ca12d56a7065035991db2a6232cd4555 (patch)
treefaadc92d840bad502c7130674dc8433c23d6ae30 /games-puzzle
parentConvert to ruby-ng. (diff)
downloadgentoo-2-9cdb7326ca12d56a7065035991db2a6232cd4555.tar.gz
gentoo-2-9cdb7326ca12d56a7065035991db2a6232cd4555.tar.bz2
gentoo-2-9cdb7326ca12d56a7065035991db2a6232cd4555.zip
Fix building with live ebuild (bug #323629); honor CC and LDFLAGS; make release and live ebuild converge a bit more
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog7
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild18
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild28
3 files changed, 37 insertions, 16 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index 5aff49f15249..6955613a0df4 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/sgt-puzzles
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.3 2010/04/01 16:41:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.4 2010/06/29 17:09:46 mr_bones_ Exp $
+
+ 29 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ sgt-puzzles-8906.ebuild, sgt-puzzles-99999999.ebuild:
+ Fix building with live ebuild (bug #323629); honor CC and LDFLAGS; make
+ release and live ebuild converge a bit more
*sgt-puzzles-8906 (01 Apr 2010)
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild
index d8641844e6df..e3e177838814 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild,v 1.1 2010/04/01 16:41:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild,v 1.2 2010/06/29 17:09:46 mr_bones_ Exp $
EAPI=2
-inherit eutils games
+inherit eutils toolchain-funcs games
if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles/trunk"
+ ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
inherit subversion
SRC_URI=""
KEYWORDS=""
@@ -24,6 +24,7 @@ IUSE="doc"
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
+ dev-lang/perl
dev-util/pkgconfig
doc? ( >=app-doc/halibut-1.0 )"
@@ -37,7 +38,7 @@ src_prepare() {
}
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" || die
if use doc ; then
halibut --text --html --info --pdf --ps puzzles.but
fi
@@ -53,8 +54,13 @@ src_install() {
[[ ${file} == "nullgame.R" ]] && continue
name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
file=${file%.R}
- newicon icons/${file}-48d24.png ${PN}-${file}.png || die
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ if [[ ${PV} -lt 99999999 ]] ; then
+ newicon icons/${file}-48d24.png ${PN}-${file}.png || die
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ else
+ # No icons with the live version
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
+ fi
done
dodoc puzzles.txt puzzles.chm
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
index 76ac61958153..e75cece60a1e 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild,v 1.3 2010/04/02 18:23:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild,v 1.4 2010/06/29 17:09:46 mr_bones_ Exp $
EAPI=2
inherit eutils toolchain-funcs games
if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles/trunk"
+ ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
inherit subversion
SRC_URI=""
KEYWORDS=""
@@ -24,15 +24,20 @@ IUSE="doc"
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
+ dev-lang/perl
dev-util/pkgconfig
doc? ( >=app-doc/halibut-1.0 )"
src_prepare() {
sed -i \
+ -e 's/-O2 -Wall -Werror -ansi -pedantic -g//' \
+ -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
+ mkfiles.pl \
+ || die
+ ./mkfiles.pl
+ sed -i \
-e '1iPKG_CONFIG ?= pkg-config' \
-e '/^GTK_CONFIG/s:=.*:= $(PKG_CONFIG) gtk+-2.0:' \
- -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:+= $(CPPFLAGS):' \
- -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
Makefile || die
}
@@ -46,21 +51,26 @@ src_compile() {
src_install() {
dodir "${GAMES_BINDIR}"
emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install || die
- dodoc README HACKING
+ dodoc README
- local file name size
+ local file name
for file in *.R ; do
[[ ${file} == "nullgame.R" ]] && continue
name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
file=${file%.R}
- newicon icons/${file}-48d24.png ${PN}-${file}.png || die
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ if [[ ${PV} -lt 99999999 ]] ; then
+ newicon icons/${file}-48d24.png ${PN}-${file}.png || die
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ else
+ # No icons with the live version
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
+ fi
done
if use doc ; then
dohtml *.html
doinfo puzzles.info
- dodoc puzzles.txt puzzles.pdf puzzles.ps
+ dodoc puzzles.pdf puzzles.ps puzzles.txt puzzles.chm
fi
prepgamesdirs