summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 22:02:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 22:02:54 +0000
commit9b6f83b6ddff803d6c1fa557636072360095a695 (patch)
treefd4150f8a4f95b0b9ab9fb206642a6ab608af830 /games-puzzle
parentold (diff)
downloadgentoo-2-9b6f83b6ddff803d6c1fa557636072360095a695.tar.gz
gentoo-2-9b6f83b6ddff803d6c1fa557636072360095a695.tar.bz2
gentoo-2-9b6f83b6ddff803d6c1fa557636072360095a695.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/fish-fillets/ChangeLog10
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-1.0.0.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/games-puzzle/fish-fillets/ChangeLog b/games-puzzle/fish-fillets/ChangeLog
index b8593f9d74a7..187a438c82fa 100644
--- a/games-puzzle/fish-fillets/ChangeLog
+++ b/games-puzzle/fish-fillets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/fish-fillets
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.47 2010/05/25 18:44:27 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.48 2011/01/10 22:02:54 mr_bones_ Exp $
+
+*fish-fillets-1.0.0 (10 Jan 2011)
+
+ 10 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +fish-fillets-1.0.0.ebuild:
+ version bump
25 May 2010; Joseph Jezak <josejx@gentoo.org> fish-fillets-0.9.3.ebuild:
Marked ppc stable for bug #315481.
diff --git a/games-puzzle/fish-fillets/fish-fillets-1.0.0.ebuild b/games-puzzle/fish-fillets/fish-fillets-1.0.0.ebuild
new file mode 100644
index 000000000000..f3964fb5485c
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-1.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/fish-fillets-1.0.0.ebuild,v 1.1 2011/01/10 22:02:54 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DATA_PV="1.0.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2[audio,video]
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ media-libs/smpeg
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ >=dev-lang/lua-5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_prepare() {
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r * || die "doins failed"
+ newicon images/icon.png ${PN}.png
+ make_desktop_entry fillets "Fish Fillets NG"
+ prepgamesdirs
+}