summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-10-22 20:30:06 +0000
committerChristoph Mende <angelos@gentoo.org>2007-10-22 20:30:06 +0000
commit880a64340ff4cd47804d6d9edd102e7cb4e19e0e (patch)
treee74e873b7e8b59ae34c4234d3eca1e777bbd239a /games-puzzle
parentDropping ia64 keyword, no hardware to test (diff)
downloadgentoo-2-880a64340ff4cd47804d6d9edd102e7cb4e19e0e.tar.gz
gentoo-2-880a64340ff4cd47804d6d9edd102e7cb4e19e0e.tar.bz2
gentoo-2-880a64340ff4cd47804d6d9edd102e7cb4e19e0e.zip
Fixed compilation on amd64 and ~amd64 added
(Portage version: 2.1.3.15)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/magiccube4d/ChangeLog6
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch53
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2.ebuild9
3 files changed, 63 insertions, 5 deletions
diff --git a/games-puzzle/magiccube4d/ChangeLog b/games-puzzle/magiccube4d/ChangeLog
index 9b3a598d405f..0bb41537962c 100644
--- a/games-puzzle/magiccube4d/ChangeLog
+++ b/games-puzzle/magiccube4d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/magiccube4d
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/ChangeLog,v 1.9 2007/02/22 01:13:21 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/ChangeLog,v 1.10 2007/10/22 20:30:05 angelos Exp $
+
+ 22 Oct 2007; Christoph Mende <angelos@gentoo.org>
+ +files/magiccube4d-2.2-64bit-ptr.patch, magiccube4d-2.2.ebuild:
+ Fixed compilation on amd64 and ~amd64 added
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
new file mode 100644
index 000000000000..7fbd52871887
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
@@ -0,0 +1,53 @@
+diff -Nru magiccube4d-src-2_2.orig/EventHandler.cpp magiccube4d-src-2_2/EventHandler.cpp
+--- magiccube4d-src-2_2.orig/EventHandler.cpp 2007-09-30 12:01:46.503967712 +0200
++++ magiccube4d-src-2_2/EventHandler.cpp 2007-09-30 12:03:23.489172011 +0200
+@@ -20,6 +20,7 @@
+ #include <iostream>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ #include "MagicCube.h"
+ #include "Puzzlest.h"
+@@ -415,7 +416,7 @@
+ void
+ EventHandler::undo_cb(void* argp)
+ {
+- int arg = (int) argp;
++ int arg = (intptr_t) argp;
+ struct stickerspec grip;
+ int dir;
+ int slicesmask;
+@@ -461,7 +462,7 @@
+ void
+ EventHandler::redo_cb(void* argp)
+ {
+- int arg = (int) argp;
++ int arg = (intptr_t) argp;
+ struct stickerspec grip;
+ int dir;
+ int slicesmask;
+@@ -507,7 +508,7 @@
+ void
+ EventHandler::scramble_cb(void *arg = NULL)
+ {
+- int n = (int)arg;
++ int n = (intptr_t)arg;
+ struct stickerspec grip;
+ int i, previous_face = -1;
+ int ngrips = NFACES * 3 * 3 * 3;
+@@ -855,12 +856,12 @@
+ void
+ EventHandler::newPuzzle_cb(void* arg)
+ {
+- if ((int)arg == preferences.getLength())
++ if ((intptr_t)arg == preferences.getLength())
+ {
+ reset_cb(0);
+ return;
+ }
+- preferences.setLength((int)arg);
++ preferences.setLength((intptr_t)arg);
+ int length = preferences.getLength();
+
+ polymgr->reset(length);
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
index 07e356521172..c7cae26eecd9 100644
--- a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
+++ b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.9 2006/12/06 17:10:08 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.10 2007/10/22 20:30:05 angelos Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="http://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
DEPEND="x11-libs/libXaw"
@@ -22,7 +22,8 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PN}-EventHandler.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-64bit-ptr.patch
sed -i -e "s:-Werror::" \
configure
}