summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 08:32:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 08:32:19 +0000
commit5cf86895a3da0e1c7485c3e091cdabce4df35798 (patch)
tree716bbad3a77165b828713ffa7f6b0d2e5afb7674 /games-puzzle
parentVersion bump (diff)
downloadgentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.tar.gz
gentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.tar.bz2
gentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.zip
EAPI=2; add use-based dep; fixup build process a bit
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ensemblist/ChangeLog8
-rw-r--r--games-puzzle/ensemblist/ensemblist-040126.ebuild23
-rw-r--r--games-puzzle/ensemblist/files/ensemblist-040126-build.patch41
3 files changed, 57 insertions, 15 deletions
diff --git a/games-puzzle/ensemblist/ChangeLog b/games-puzzle/ensemblist/ChangeLog
index 88ea5666ec73..3dfaf5b474be 100644
--- a/games-puzzle/ensemblist/ChangeLog
+++ b/games-puzzle/ensemblist/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/ensemblist
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ChangeLog,v 1.7 2007/02/22 01:08:00 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ChangeLog,v 1.8 2009/01/23 08:32:19 mr_bones_ Exp $
+
+ 23 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ensemblist-040126-build.patch, ensemblist-040126.ebuild:
+ EAPI=2; add use-based dep; fixup build process a bit
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/ensemblist/ensemblist-040126.ebuild b/games-puzzle/ensemblist/ensemblist-040126.ebuild
index f0b11d7a9aba..af8f1cd636f9 100644
--- a/games-puzzle/ensemblist/ensemblist-040126.ebuild
+++ b/games-puzzle/ensemblist/ensemblist-040126.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.6 2006/12/06 16:59:33 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.7 2009/01/23 08:32:19 mr_bones_ Exp $
-inherit games
+EAPI=2
+inherit eutils games
DESCRIPTION="Put together several primitives to build a given shape. (C.S.G. Game)"
HOMEPAGE="http://www.nongnu.org/ensemblist/index_en.html"
@@ -18,17 +19,12 @@ DEPEND="x11-libs/libXmu
virtual/glut
virtual/glu
media-libs/libpng
- media-libs/libmikmod"
+ media-libs/libmikmod[oss]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CC/d' \
- -e '/strip/d' \
- -e "s:^DATADIR=.*:DATADIR=${GAMES_DATADIR}/${PN}/datas:" \
- -e "/^COMPILE_FLAGS/s/-Wall -O3 -fomit-frame-pointer/${CFLAGS}/" \
- Makefile || die "sed failed"
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake DATADIR="\"${GAMES_DATADIR}\"/${PN}/datas" || die "emake failed"
}
src_install() {
@@ -36,5 +32,6 @@ src_install() {
insinto "${GAMES_DATADIR}/${PN}"
doins -r datas || die "doins failed"
dodoc README Changelog
+ make_desktop_entry ${PN} Ensemblist
prepgamesdirs
}
diff --git a/games-puzzle/ensemblist/files/ensemblist-040126-build.patch b/games-puzzle/ensemblist/files/ensemblist-040126-build.patch
new file mode 100644
index 000000000000..42cc04070eef
--- /dev/null
+++ b/games-puzzle/ensemblist/files/ensemblist-040126-build.patch
@@ -0,0 +1,41 @@
+diff -ru ensemblist-040126.orig/Makefile ensemblist-040126/Makefile
+--- ensemblist-040126.orig/Makefile 2004-01-26 10:37:05.000000000 -0500
++++ ensemblist-040126/Makefile 2009-01-23 03:24:05.000000000 -0500
+@@ -1,17 +1,8 @@
+ NAME=ensemblist
+-CC=gcc
+-ifdef DEBUG
+-DATADIR=/home/rixed/src/ensemblist/datas
+-COMPILE_FLAGS=-Wall -fno-builtin -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wredundant-decls -O0 -g `libmikmod-config --cflags` -DDATADIR=$(DATADIR)
+-LINK_FLAGS=-g -lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lefence -lpthread
+-else
+ DATADIR=$(DESTDIR)/usr/share/$(NAME)
+-COMPILE_FLAGS=-Wall -O3 -fomit-frame-pointer `libmikmod-config --cflags` -DNDEBUG -DDATADIR=$(DATADIR)
+-LINK_FLAGS=-lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lpthread
+-endif
++COMPILE_FLAGS=`libmikmod-config --cflags` -DDATADIR=$(DATADIR)
++LINK_FLAGS=-L/usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lpthread -lm
+ APPLE_FRAMEWORKS=-framework GLUT -framework Cocoa -framework OpenGL
+-#uncomment the following if you want to compile on MacOS/X
+-#LINK_FLAGS=$(LINK_FLAGS) $(APPLE_FRAMEWORKS)
+ CFILES=$(wildcard *.c)
+ OFILES=$(patsubst %.c,%.o,$(CFILES))
+
+@@ -22,15 +13,10 @@
+ all: $(NAME)
+
+ $(NAME): $(OFILES)
+- @echo '$(COL)$@$(NORM)'
+- $(CC) $(COMPILE_FLAGS) $(LINK_FLAGS) $^ -o $@
+-ifndef DEBUG
+- strip $(NAME)
+-endif
++ $(CC) $(CFLAGSLD) $(COMPILE_FLAGS) $^ -o $@ $(LINK_FLAGS)
+
+ .c.o:
+- @echo '$(COL)$@$(NORM)'
+- $(CC) $(COMPILE_FLAGS) -c $<
++ $(CC) $(CFLAGS) $(COMPILE_FLAGS) -c $<
+
+ clean:
+ @echo '$(COL)$@$(NORM)'