summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-31 08:55:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-31 08:55:43 +0000
commit519fcf618053f49656486a3cf3bcebb3af54952b (patch)
treed17593999c9d668333b0920596939cf39e73397c /games-puzzle
parenttouch (diff)
downloadgentoo-2-519fcf618053f49656486a3cf3bcebb3af54952b.tar.gz
gentoo-2-519fcf618053f49656486a3cf3bcebb3af54952b.tar.bz2
gentoo-2-519fcf618053f49656486a3cf3bcebb3af54952b.zip
tidy
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/groundhog/groundhog-1.4.ebuild10
-rw-r--r--games-puzzle/sdlvexed/ChangeLog7
-rw-r--r--games-puzzle/sdlvexed/sdlvexed-0.6.ebuild17
-rw-r--r--games-puzzle/wakkabox/wakkabox-1.1.0.ebuild6
4 files changed, 20 insertions, 20 deletions
diff --git a/games-puzzle/groundhog/groundhog-1.4.ebuild b/games-puzzle/groundhog/groundhog-1.4.ebuild
index 88641c5544a4..9b2a0d4f3c8e 100644
--- a/games-puzzle/groundhog/groundhog-1.4.ebuild
+++ b/games-puzzle/groundhog/groundhog-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.11 2004/12/28 15:55:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.12 2005/10/31 08:54:59 mr_bones_ Exp $
inherit eutils gnuconfig games
@@ -10,7 +10,7 @@ SRC_URI="http://home-2.consunet.nl/~cb007736/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 ppc"
+KEYWORDS="~amd64 ppc x86"
IUSE="nls"
DEPEND="virtual/x11
@@ -19,8 +19,8 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${PV}-gcc3.patch"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gcc3.patch
}
src_compile() {
@@ -30,7 +30,7 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README NEWS AUTHORS TODO Changelog
prepgamesdirs
}
diff --git a/games-puzzle/sdlvexed/ChangeLog b/games-puzzle/sdlvexed/ChangeLog
index 482054497c97..addd82744743 100644
--- a/games-puzzle/sdlvexed/ChangeLog
+++ b/games-puzzle/sdlvexed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/sdlvexed
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sdlvexed/ChangeLog,v 1.6 2004/11/22 12:52:08 josejx Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sdlvexed/ChangeLog,v 1.7 2005/10/31 08:52:41 mr_bones_ Exp $
+
+ 31 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org> sdlvexed-0.6.ebuild:
+ tidy
22 Nov 2004; Joseph Jezak <josejx@gentoo.org> sdlvexed-0.6.ebuild:
Marked ppc stable.
diff --git a/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild b/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild
index 668d697f3336..de6520339490 100644
--- a/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild
+++ b/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild,v 1.3 2004/11/22 12:52:08 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sdlvexed/sdlvexed-0.6.ebuild,v 1.4 2005/10/31 08:52:41 mr_bones_ Exp $
inherit games
@@ -10,19 +10,16 @@ SRC_URI="http://core.segfault.pl/~krzynio/vexed/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
-RDEPEND="virtual/libc
- >=dev-lang/perl-5.6.1
+DEPEND=">=dev-lang/perl-5.6.1
>=media-libs/sdl-mixer-1.2.3
>=dev-perl/sdl-perl-1.19.0"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mv vexed sdlvexed
sed -i \
-e "/PREFIX=/s:\.:${GAMES_DATADIR}/${PN}:" sdlvexed \
@@ -32,8 +29,8 @@ src_unpack() {
src_install() {
dogamesbin sdlvexed || die "dogamesbin failed"
- dodir "${GAMES_DATADIR}/${PN}"
- cp -R {gfx,levelpacks} "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r {gfx,levelpacks} || die "doins failed"
dodoc CHANGELOG README
prepgamesdirs
}
diff --git a/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild b/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
index dcb78df6646b..85ffa0302c1a 100644
--- a/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
+++ b/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild,v 1.7 2004/12/28 16:42:52 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild,v 1.8 2005/10/31 08:55:43 mr_bones_ Exp $
inherit games
@@ -10,13 +10,13 @@ SRC_URI="http://kenn.frap.net/wakkabox/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="ppc x86"
IUSE=""
DEPEND=">=media-libs/libsdl-1.0.1"
src_install() {
- egamesinstall || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS NEWS README
prepgamesdirs
}