summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:50:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:50:50 +0000
commit4a0eb24cb4018127611229760d185f97aa6f8bae (patch)
tree59f40450046695914e01660fa57e2707f5656ba0 /games-puzzle/zaz
parentVersion bump (diff)
downloadgentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.tar.gz
gentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.tar.bz2
gentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/zaz')
-rw-r--r--games-puzzle/zaz/ChangeLog8
-rw-r--r--games-puzzle/zaz/files/zaz-1.0.0-build.patch19
-rw-r--r--games-puzzle/zaz/zaz-1.0.0.ebuild47
3 files changed, 73 insertions, 1 deletions
diff --git a/games-puzzle/zaz/ChangeLog b/games-puzzle/zaz/ChangeLog
index 82c9863e99bc..d7e9e5f42624 100644
--- a/games-puzzle/zaz/ChangeLog
+++ b/games-puzzle/zaz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/zaz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.11 2010/07/11 12:34:33 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.12 2010/09/04 07:50:50 mr_bones_ Exp $
+
+*zaz-1.0.0 (04 Sep 2010)
+
+ 04 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> +zaz-1.0.0.ebuild,
+ +files/zaz-1.0.0-build.patch:
+ version bump
11 Jul 2010; Christian Faulhammer <fauli@gentoo.org> zaz-0.7.0.ebuild:
stable x86, bug 325367
diff --git a/games-puzzle/zaz/files/zaz-1.0.0-build.patch b/games-puzzle/zaz/files/zaz-1.0.0-build.patch
new file mode 100644
index 000000000000..bef2954bf088
--- /dev/null
+++ b/games-puzzle/zaz/files/zaz-1.0.0-build.patch
@@ -0,0 +1,19 @@
+diff -ru zaz-0.7.0.orig/Makefile.am zaz-0.7.0/Makefile.am
+--- zaz-0.7.0.orig/Makefile.am 2009-10-14 18:20:14.000000000 -0400
++++ zaz-0.7.0/Makefile.am 2010-05-13 15:49:59.404464060 -0400
+@@ -2,15 +2,6 @@
+
+ SUBDIRS = po src data extra
+
+-dist_doc_DATA = \
+- README\
+- COPYING\
+- AUTHORS\
+- ChangeLog\
+- INSTALL\
+- NEWS
+-
+-
+ EXTRA_DIST = config.rpath m4/ChangeLog\
+ $(shared_data_DATA) \
+ zaz.anjuta\
diff --git a/games-puzzle/zaz/zaz-1.0.0.ebuild b/games-puzzle/zaz/zaz-1.0.0.ebuild
new file mode 100644
index 000000000000..cc8a5e995e67
--- /dev/null
+++ b/games-puzzle/zaz/zaz-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-1.0.0.ebuild,v 1.1 2010/09/04 07:50:50 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="http://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,audio,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog
+ prepgamesdirs
+}