summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commit36f033373c281af1793a0bdc033d004e9d129f59 (patch)
tree29e637012cd09fb89fbc62b23f6474d0c4ba2bec /games-puzzle/xwelltris
parentnative widget stuff now also for gtk (diff)
downloadgentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.gz
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.bz2
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/xwelltris')
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 9a23bef61770..eb5d1eba9b77 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.4 2004/03/07 20:51:56 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.5 2004/05/12 09:02:46 mr_bones_ Exp $
inherit games
@@ -22,21 +22,21 @@ DEPEND="${RDEPEND}
src_compile() {
# configure/build process is pretty messed up
- egamesconf `use_with sdl` || die
+ egamesconf $(use_with sdl) || die
sed -i \
-e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
- src/include/globals.h || \
- die "sed src/include/globals.h failed"
+ src/include/globals.h \
+ || die "sed src/include/globals.h failed"
emake || die "emake failed"
}
src_install() {
- dodir ${GAMES_BINDIR} ${GAMES_DATADIR}/${PN} /usr/share/man
+ dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" /usr/share/man
make install \
- INSTDIR=${D}/${GAMES_BINDIR} \
- INSTLIB=${D}/${GAMES_DATADIR}/${PN} \
+ INSTDIR="${D}/${GAMES_BINDIR}" \
+ INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
INSTMAN=/usr/share/man \
|| die "make install failed"
- dodoc AUTHORS Changelog README* || die "dodoc failed"
+ dodoc AUTHORS Changelog README*
prepgamesdirs
}