summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-05 09:16:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-05 09:16:25 +0000
commit8252ccbb727405aa0fa48e20fef7806714d23b71 (patch)
tree8364c493c7dda6326536a05892f6d8ea03aa201b /games-puzzle/torrent
parentmarked stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-8252ccbb727405aa0fa48e20fef7806714d23b71.tar.gz
gentoo-2-8252ccbb727405aa0fa48e20fef7806714d23b71.tar.bz2
gentoo-2-8252ccbb727405aa0fa48e20fef7806714d23b71.zip
initial commit
Diffstat (limited to 'games-puzzle/torrent')
-rw-r--r--games-puzzle/torrent/ChangeLog10
-rw-r--r--games-puzzle/torrent/Manifest2
-rw-r--r--games-puzzle/torrent/files/digest-torrent-0.81
-rw-r--r--games-puzzle/torrent/metadata.xml5
-rw-r--r--games-puzzle/torrent/torrent-0.8.ebuild32
5 files changed, 50 insertions, 0 deletions
diff --git a/games-puzzle/torrent/ChangeLog b/games-puzzle/torrent/ChangeLog
new file mode 100644
index 000000000000..4659ccf07901
--- /dev/null
+++ b/games-puzzle/torrent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/torrent
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/ChangeLog,v 1.1 2004/03/05 09:16:25 mr_bones_ Exp $
+
+*torrent-0.8 (05 Mar 2004)
+
+ 05 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ torrent-0.8.ebuild:
+ initial commit
+
diff --git a/games-puzzle/torrent/Manifest b/games-puzzle/torrent/Manifest
new file mode 100644
index 000000000000..7aea94bb0468
--- /dev/null
+++ b/games-puzzle/torrent/Manifest
@@ -0,0 +1,2 @@
+MD5 7d6defcf35b8c0a33c2aefb3c18d49ba torrent-0.8.ebuild 868
+MD5 6a3cfa6b20bb08ba4772b9e714bedd75 files/digest-torrent-0.8 63
diff --git a/games-puzzle/torrent/files/digest-torrent-0.8 b/games-puzzle/torrent/files/digest-torrent-0.8
new file mode 100644
index 000000000000..3f66ee0ab310
--- /dev/null
+++ b/games-puzzle/torrent/files/digest-torrent-0.8
@@ -0,0 +1 @@
+MD5 fe642129b2616f2a1633037782f1fad5 torrent-0.8.tar.gz 548970
diff --git a/games-puzzle/torrent/metadata.xml b/games-puzzle/torrent/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/torrent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/torrent/torrent-0.8.ebuild b/games-puzzle/torrent/torrent-0.8.ebuild
new file mode 100644
index 000000000000..abd62c0d8d77
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/torrent-0.8.ebuild,v 1.1 2004/03/05 09:16:25 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Match rising tiles to score as many points as possible before the tiles touch the top of the board"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir=${GAMES_DATADIR_BASE} \
+ || die
+ emake || die "emake faile"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ prepgamesdirs
+}