summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 16:09:02 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 16:09:02 +0000
commit14dd4857b07221f53b12eb66cf297801d06615f7 (patch)
tree073576ec7adf503d08399eaf06762f29371bb44a /games-puzzle/tint
parentFixed binaries being pre-stripped. Thanks to Tristan Heaven <tristanheaven@g... (diff)
downloadgentoo-2-14dd4857b07221f53b12eb66cf297801d06615f7.tar.gz
gentoo-2-14dd4857b07221f53b12eb66cf297801d06615f7.tar.bz2
gentoo-2-14dd4857b07221f53b12eb66cf297801d06615f7.zip
Fixed binaries being pre-stripped. Thanks to Tristan Heaven <tristanheaven@gmail.com> for the patch. Closing bug #137726.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'games-puzzle/tint')
-rw-r--r--games-puzzle/tint/ChangeLog8
-rw-r--r--games-puzzle/tint/tint-0.03a.ebuild10
2 files changed, 12 insertions, 6 deletions
diff --git a/games-puzzle/tint/ChangeLog b/games-puzzle/tint/ChangeLog
index 50dff7278dc4..c8322b5963a9 100644
--- a/games-puzzle/tint/ChangeLog
+++ b/games-puzzle/tint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/tint
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/ChangeLog,v 1.6 2005/12/23 11:07:41 nigoro Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/ChangeLog,v 1.7 2006/06/29 16:09:02 wolf31o2 Exp $
+
+ 29 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> tint-0.03a.ebuild:
+ Fixed binaries being pre-stripped. Thanks to Tristan Heaven
+ <tristanheaven@gmail.com> for the patch. Closing bug #137726.
23 Dec 2005; Yuta SATOH <nigoro@gentoo.org> tint-0.03a.ebuild:
Stable on ppc64
diff --git a/games-puzzle/tint/tint-0.03a.ebuild b/games-puzzle/tint/tint-0.03a.ebuild
index f914621c6175..d468451b6685 100644
--- a/games-puzzle/tint/tint-0.03a.ebuild
+++ b/games-puzzle/tint/tint-0.03a.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03a.ebuild,v 1.6 2005/12/23 11:07:41 nigoro Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03a.ebuild,v 1.7 2006/06/29 16:09:02 wolf31o2 Exp $
inherit eutils games
MY_P=${P/-/_}
DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
-SRC_URI="http://oasis.frogfoot.net/code/tint/download/$PV/$MY_P.tar.gz"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/${PV}/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
@@ -17,14 +17,16 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.4-r1"
src_unpack() {
- unpack $A
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PV}-warnings.patch"
+ sed -i '/STRIP/d' Makefile || die "sed failed"
}
src_compile() {
emake \
CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
localstatedir="${GAMES_STATEDIR}" \
|| die "emake failed"
}