summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-09-25 12:50:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-09-25 12:50:28 +0000
commitb1e9dc7c051e3e4f2f11039e26c862c06e482969 (patch)
tree5084cbeba6f6298d8072d3785c5038529ebbd0a9 /games-puzzle/pingus
parentPEER_DNS now allows OpenVPN to create /etc/resolv.conf or not, #193668 (diff)
downloadgentoo-2-b1e9dc7c051e3e4f2f11039e26c862c06e482969.tar.gz
gentoo-2-b1e9dc7c051e3e4f2f11039e26c862c06e482969.tar.bz2
gentoo-2-b1e9dc7c051e3e4f2f11039e26c862c06e482969.zip
Version bump, bug #190206
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog10
-rw-r--r--games-puzzle/pingus/files/digest-pingus-0.7.13
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.1-paths.patch34
-rw-r--r--games-puzzle/pingus/pingus-0.7.1.ebuild50
4 files changed, 95 insertions, 2 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index ecced3e3cc13..516083d2d63f 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.11 2006/11/04 04:56:55 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.12 2007/09/25 12:50:27 nyhm Exp $
+
+*pingus-0.7.1 (25 Sep 2007)
+
+ 25 Sep 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/pingus-0.7.1-paths.patch, +pingus-0.7.1.ebuild:
+ Version bump, bug #190206
04 Nov 2006; Tristan Heaven <nyhm@gentoo.org>
+files/pingus-0.6.0-build.patch, pingus-0.6.0-r1.ebuild:
diff --git a/games-puzzle/pingus/files/digest-pingus-0.7.1 b/games-puzzle/pingus/files/digest-pingus-0.7.1
new file mode 100644
index 000000000000..cb81a07f2d55
--- /dev/null
+++ b/games-puzzle/pingus/files/digest-pingus-0.7.1
@@ -0,0 +1,3 @@
+MD5 b4fcf66d0dc5e1d6148447988f87d3b1 pingus-0.7.1.tar.bz2 10648862
+RMD160 a9fab65a9966999cc3cb16e03122404f8372df7b pingus-0.7.1.tar.bz2 10648862
+SHA256 90772f82bc1b9655541feb6471573fcbe375a633a858fcf5798ad8160ae89fb5 pingus-0.7.1.tar.bz2 10648862
diff --git a/games-puzzle/pingus/files/pingus-0.7.1-paths.patch b/games-puzzle/pingus/files/pingus-0.7.1-paths.patch
new file mode 100644
index 000000000000..6adf00beaee8
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.1-paths.patch
@@ -0,0 +1,34 @@
+--- install.sh
++++ install.sh
+@@ -14,8 +14,8 @@
+ exit 1
+ fi
+
+- BINDIR="$1/bin/"
+- DATADIR="$1/share/pingus/"
++ BINDIR="${1}GENTOO_BINDIR"
++ DATADIR="${1}GENTOO_DATADIR"
+
+ echo "Installing Pingus in: $1"
+
+--- SConstruct
++++ SConstruct
+@@ -406,7 +406,6 @@
+
+ config_h = open('config.h', 'w')
+ config_h.write('#define VERSION "0.7.1"\n')
+- config_h.write('#define ENABLE_BINRELOC 1\n')
+ config_h.write('#define ICONV_CONST\n') # FIXME: make a check for this
+ for (v,k) in config_h_defines:
+ config_h.write('#define %s %s\n' % (v, k))
+--- src/pingus_main.cpp
++++ src/pingus_main.cpp
+@@ -583,7 +583,7 @@
+ path_manager.add_path("data"); // assume game is run from source dir, without any magic
+ free(exe_path);
+ #else
+- path_manager.add_path("data"); // assume game is run from source dir
++ path_manager.add_path("GENTOO_DATADIR/data");
+ #endif
+
+ if (!path_manager.find_path("data/core.res"))
diff --git a/games-puzzle/pingus/pingus-0.7.1.ebuild b/games-puzzle/pingus/pingus-0.7.1.ebuild
new file mode 100644
index 000000000000..1dedac239fbb
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.1.ebuild,v 1.1 2007/09/25 12:50:27 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/libpng
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.97"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-paths.patch
+ sed -i \
+ -e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ install.sh src/pingus_main.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ scons configure \
+ CXX="$(tc-getCXX)" \
+ CCFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ || die "scons configure failed"
+ scons || die "scons failed"
+}
+
+src_install() {
+ ./install.sh "${D}" || die "install.sh failed"
+ newicon data/images/pingus/player0/boarder.png ${PN}.png
+ make_desktop_entry ${PN} Pingus
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}