summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit2f7b073c1bc54c873666c4522cd6cd49ac1d59df (patch)
tree072f3e7b49f6b078b595b1483277009b1f03d0f6 /games-puzzle/pingus/pingus-0.6.0-r1.ebuild
parentgames-puzzle (diff)
downloadgentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.gz
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.bz2
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/pingus/pingus-0.6.0-r1.ebuild')
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..a1e2104f884b
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/hermes-1.3.2-r2
+ =dev-games/clanlib-0.6.5*
+ >=dev-libs/libxml2-2.5.6"
+
+pkg_setup() {
+ clanlib-config 0.6.5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ egamesconf \
+ --with-bindir=${GAMES_BINDIR} \
+ --with-datadir=${GAMES_DATADIR_BASE} \
+ `use_with opengl clanGL` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ # pos install process ... FIXME
+ mv ${D}/usr/games/{games,bin}
+ cd ${D}/usr/share/games
+ mv locale ../
+ mv games/pingus .
+ rm -rf games
+ # end pos install process
+ prepgamesdirs
+}