summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commit36f033373c281af1793a0bdc033d004e9d129f59 (patch)
tree29e637012cd09fb89fbc62b23f6474d0c4ba2bec /games-puzzle/pathological
parentnative widget stuff now also for gtk (diff)
downloadgentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.gz
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.bz2
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/pathological')
-rw-r--r--games-puzzle/pathological/pathological-1.1.3.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/games-puzzle/pathological/pathological-1.1.3.ebuild b/games-puzzle/pathological/pathological-1.1.3.ebuild
index cd94b6c3292b..718cfc64a572 100644
--- a/games-puzzle/pathological/pathological-1.1.3.ebuild
+++ b/games-puzzle/pathological/pathological-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pathological/pathological-1.1.3.ebuild,v 1.2 2004/02/20 06:53:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pathological/pathological-1.1.3.ebuild,v 1.3 2004/05/12 09:02:46 mr_bones_ Exp $
inherit games
@@ -23,11 +23,11 @@ src_unpack() {
use doc && {
sed -i \
- -e '5,$ s/=/ /g' makehtml || \
- die "sed makehtml failed"
+ -e '5,$ s/=/ /g' makehtml \
+ || die "sed makehtml failed"
} || {
- echo "#!/bin/sh" > makehtml || \
- die "clearing makehtml failed"
+ echo "#!/bin/sh" > makehtml \
+ || die "clearing makehtml failed"
}
sed -i \
@@ -41,24 +41,25 @@ src_unpack() {
src_install() {
# executables
- dogamesbin pathological
- insinto ${GAMES_DATADIR}/${PN}
+ dogamesbin pathological || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
insopts -m0750
- doins pathological.py
- exeinto ${GAMES_LIBDIR}/${PN}
- doexe write-highscores
+ doins pathological.py || die "doins failed"
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe write-highscores || die "doexe failed"
# removed some unneeded resource files
rm -f graphics/*.xcf
rm -f sounds/*.orig
# "install" resource files
# Use cp, not mv so install can be done multiple times (for ebuild devel).
- cp -R circuits graphics music sounds ${D}/${GAMES_DATADIR}/${PN}
+ cp -R circuits graphics music sounds "${D}/${GAMES_DATADIR}/${PN}" \
+ || die "cp failed"
# setup high score file
- insinto ${GAMES_STATEDIR}
+ insinto "${GAMES_STATEDIR}"
insopts -m0664
- doins pathological_scores
+ doins pathological_scores || die "doins failed (pathological_scores)"
# documentation
dodoc README TODO