summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-14 21:56:52 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-14 21:56:52 +0000
commit07fdfacd40e621a5cb1fc318f37d1dbd7ed9f355 (patch)
treefbc0e1b0c3721c84ce84aebff59b5e91b36a254e /games-puzzle/monsterz
parentfixed dependencies (solves bug #221489). (diff)
downloadgentoo-2-07fdfacd40e621a5cb1fc318f37d1dbd7ed9f355.tar.gz
gentoo-2-07fdfacd40e621a5cb1fc318f37d1dbd7ed9f355.tar.bz2
gentoo-2-07fdfacd40e621a5cb1fc318f37d1dbd7ed9f355.zip
Patch from Debian for bug #208329
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/ChangeLog8
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch26
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r1.ebuild44
3 files changed, 77 insertions, 1 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index 70ec7e54218d..5fb1160d6116 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/monsterz
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.15 2008/03/15 03:53:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.16 2008/05/14 21:56:51 nyhm Exp $
+
+*monsterz-0.7.1-r1 (14 May 2008)
+
+ 14 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/monsterz-0.7.1-64bit.patch, +monsterz-0.7.1-r1.ebuild:
+ Patch from Debian for bug #208329
*monsterz-0.7.1 (15 Mar 2008)
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
new file mode 100644
index 000000000000..64d6527768f8
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
@@ -0,0 +1,26 @@
+Index: monsterz-0.7.1/monsterz.py
+===================================================================
+--- monsterz-0.7.1.orig/monsterz.py 2008-05-09 16:35:25.000000000 +0000
++++ monsterz-0.7.1/monsterz.py 2008-05-09 16:35:33.000000000 +0000
+@@ -108,7 +108,9 @@
+ M = int(max(r, g, b))
+ m = int(min(r, g, b))
+ val = (2 * M + r + g + b) / 5
+- p[:] = (val + r) / 2, (val + g) / 2, (val + b) / 2
++ p[0] = (val + r) / 2
++ p[1] = (val + g) / 2
++ p[2] = (val + b) / 2
+ if alpha[y][x] >= 250:
+ alpha[y][x] = 255 - (M - m) * 3 / 4
+ del pixels
+@@ -129,7 +131,9 @@
+ r, g, b = p
+ M = int(max(r, g, b))
+ m = int(min(r, g, b))
+- p[:] = (m + r) / 2, (m + g) / 2, (m + b) / 2
++ p[0] = (m + r) / 2
++ p[1] = (m + g) / 2
++ p[2] = (m + b) / 2
+ if alpha[y][x] >= 250:
+ alpha[y][x] = 255 - M * 2 / 3
+ del pixels
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r1.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..0534b222f90d
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.7.1-r1.ebuild,v 1.1 2008/05/14 21:56:51 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "${PN} requires that media-libs/sdl-mixer be built with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics sound || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "newgamesbin failed"
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ prepgamesdirs
+}