summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-04-20 08:36:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-04-20 08:36:39 +0000
commit84fee6a0ef05f62bd4bbb0bd5ec6c12b136e84bc (patch)
treecf1926c04f54cdc0894d075e3d76dc0c81812bf9 /games-puzzle/kiki
parentDisable tests since they require no rpc.statd to be running on the system bef... (diff)
downloadgentoo-2-84fee6a0ef05f62bd4bbb0bd5ec6c12b136e84bc.tar.gz
gentoo-2-84fee6a0ef05f62bd4bbb0bd5ec6c12b136e84bc.tar.bz2
gentoo-2-84fee6a0ef05f62bd4bbb0bd5ec6c12b136e84bc.zip
Force python2. Fix bug #312267
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/kiki')
-rw-r--r--games-puzzle/kiki/ChangeLog7
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r2.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index 8473f1de9647..3e96d7aab54b 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/kiki
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.15 2009/06/16 20:28:29 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.16 2010/04/20 08:36:39 tupone Exp $
+
+ 20 Apr 2010; Tupone Alfredo <tupone@gentoo.org> kiki-1.0.2-r2.ebuild:
+ Force python2. Fix bug #312267 by arfrever@gentoo.org
16 Jun 2009; Tristan Heaven <nyhm@gentoo.org> kiki-1.0.2-r2.ebuild,
+files/kiki-1.0.2-build.patch:
diff --git a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
index 7d9b9900b7a1..c52b29d63d16 100644
--- a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
+++ b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.4 2009/06/16 20:28:29 nyhm Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.5 2010/04/20 08:36:39 tupone Exp $
+PYTHON_DEPEND="2"
EAPI=2
inherit eutils python toolchain-funcs games
@@ -17,7 +17,6 @@ IUSE=""
RDEPEND="media-libs/libsdl[opengl]
media-libs/sdl-image
media-libs/sdl-mixer
- dev-lang/python
virtual/opengl
virtual/glu
virtual/glut"
@@ -51,8 +50,7 @@ src_prepare() {
src_compile() {
emake -C kodilib/linux AR="$(tc-getAR)" || die "emake kodilib failed"
- python_version
- emake -C linux PYTHON_VERSION="${PYVER}" || die "emake linux failed"
+ emake -C linux PYTHON_VERSION="$(python_get_version)" || die "emake linux failed"
}
src_install() {
@@ -64,3 +62,8 @@ src_install() {
dodoc Readme.txt Thanks.txt
prepgamesdirs
}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}