summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-05 07:51:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-05 07:51:26 +0000
commit217c076a5433408751202b5188fb2f72ff07c811 (patch)
tree133e7114096220124c3ea37eaa093ed6232a8a11 /games-puzzle/hoh-bin
parentinitial commit; ebuild based on the one submitted by Felix Riemann via bug 36222 (diff)
downloadgentoo-2-217c076a5433408751202b5188fb2f72ff07c811.tar.gz
gentoo-2-217c076a5433408751202b5188fb2f72ff07c811.tar.bz2
gentoo-2-217c076a5433408751202b5188fb2f72ff07c811.zip
initial commit; ebuild based on the one submitted by Felix Riemann via bug 36222
Diffstat (limited to 'games-puzzle/hoh-bin')
-rw-r--r--games-puzzle/hoh-bin/ChangeLog11
-rw-r--r--games-puzzle/hoh-bin/Manifest4
-rw-r--r--games-puzzle/hoh-bin/files/digest-hoh-bin-1.01
-rw-r--r--games-puzzle/hoh-bin/hoh-bin-1.0.ebuild38
-rw-r--r--games-puzzle/hoh-bin/metadata.xml9
5 files changed, 62 insertions, 1 deletions
diff --git a/games-puzzle/hoh-bin/ChangeLog b/games-puzzle/hoh-bin/ChangeLog
new file mode 100644
index 000000000000..ed409e538169
--- /dev/null
+++ b/games-puzzle/hoh-bin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-puzzle/hoh-bin
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/ChangeLog,v 1.1 2004/01/05 07:51:20 mr_bones_ Exp $
+
+*hoh-bin-1.0 (04 Jan 2004)
+
+ 04 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> hoh-bin-1.0.ebuild,
+ metadata.xml:
+ initial commit; ebuild based on the one submitted by Felix Riemann via bug
+ 36222
+
diff --git a/games-puzzle/hoh-bin/Manifest b/games-puzzle/hoh-bin/Manifest
index 66b7b16c9215..dd3b2b1f4484 100644
--- a/games-puzzle/hoh-bin/Manifest
+++ b/games-puzzle/hoh-bin/Manifest
@@ -1,2 +1,4 @@
-MD5 a2c9e99b40a9942b495c0df01e0535a3 hoh-bin-1.0.ebuild 912
+MD5 c16dd70bd705d57336828272d1794c2b hoh-bin-1.0.ebuild 1110
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 cf115298d6a4d8f2769abbe318b62ade ChangeLog 430
MD5 8d0a42d849cb14f23285c2a747566b66 files/digest-hoh-bin-1.0 64
diff --git a/games-puzzle/hoh-bin/files/digest-hoh-bin-1.0 b/games-puzzle/hoh-bin/files/digest-hoh-bin-1.0
new file mode 100644
index 000000000000..7d30c9a78e9b
--- /dev/null
+++ b/games-puzzle/hoh-bin/files/digest-hoh-bin-1.0
@@ -0,0 +1 @@
+MD5 6a6dce88f65cd313e2ff58f59574bee4 hohlin-10.tar.bz2 14808737
diff --git a/games-puzzle/hoh-bin/hoh-bin-1.0.ebuild b/games-puzzle/hoh-bin/hoh-bin-1.0.ebuild
new file mode 100644
index 000000000000..7993074fe364
--- /dev/null
+++ b/games-puzzle/hoh-bin/hoh-bin-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/hoh-bin-1.0.ebuild,v 1.1 2004/01/05 07:51:20 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/hoh-install-1.0"
+DESCRIPTION="PC remake of the spectrum game"
+HOMEPAGE="http://retrospec.sgn.net/games/hoh/"
+SRC_URI="http://retrospec.sgn.net/download.php?id=63\&path=games/hoh/bin/hohlin-${PV/./}.tar.bz2"
+
+RESTRICT="nostrip"
+KEYWORDS="x86"
+LICENSE="free-noncomm"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ cat > "${T}/hoh" <<-EOF
+ #!/bin/bash
+ export LD_LIBRARY_PATH="${GAMES_PREFIX_OPT}/HoH/data/runtime"
+ cd "${GAMES_PREFIX_OPT}/HoH/data"
+ exec ./HoH \$@
+EOF
+}
+
+src_install() {
+ local DATADIR="${GAMES_PREFIX_OPT}/HoH/data"
+ local DOCDIR="${GAMES_PREFIX_OPT}/HoH/docs"
+
+ dogamesbin "${T}/hoh" || die "dogames bin failed"
+ dodir "${DATADIR}" "${DOCDIR}" || die "dodir failed"
+ cp -af data/* "${D}/${DATADIR}/" || die "cp failed (data)"
+ cp -af docs/* "${D}/${DOCDIR}/" || die "cp failed (docs)"
+ prepgamesdirs
+}
diff --git a/games-puzzle/hoh-bin/metadata.xml b/games-puzzle/hoh-bin/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-puzzle/hoh-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>