summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-05-08 05:05:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-05-08 05:05:35 +0000
commitdd13f6ca74b2edc35c7c5287cb97b76b1e5ddc1a (patch)
tree49003dd47fc286619d5a6350e38a0f5a4b8f0726 /games-puzzle/enigma
parentdev-python/rst2pdf svg support fixes bug #403407 (diff)
downloadgentoo-2-dd13f6ca74b2edc35c7c5287cb97b76b1e5ddc1a.tar.gz
gentoo-2-dd13f6ca74b2edc35c7c5287cb97b76b1e5ddc1a.tar.bz2
gentoo-2-dd13f6ca74b2edc35c7c5287cb97b76b1e5ddc1a.zip
version bump (bug #468922)
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/enigma')
-rw-r--r--games-puzzle/enigma/ChangeLog10
-rw-r--r--games-puzzle/enigma/enigma-1.20.ebuild71
-rw-r--r--games-puzzle/enigma/files/enigma-1.20-autotools.patch132
3 files changed, 211 insertions, 2 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index 8026bcfb914d..0b7f4474a59e 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/enigma
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.52 2012/09/28 12:24:34 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.53 2013/05/08 05:05:35 mr_bones_ Exp $
+
+*enigma-1.20 (08 May 2013)
+
+ 08 May 2013; Michael Sterrett <mr_bones_@gentoo.org> +enigma-1.20.ebuild,
+ +files/enigma-1.20-autotools.patch:
+ version bump (bug #468922)
28 Sep 2012; Tupone Alfredo <tupone@gentoo.org> enigma-1.01.ebuild,
+files/enigma-1.01-gcc47.patch:
diff --git a/games-puzzle/enigma/enigma-1.20.ebuild b/games-puzzle/enigma/enigma-1.20.ebuild
new file mode 100644
index 000000000000..4208c9e119cb
--- /dev/null
+++ b/games-puzzle/enigma/enigma-1.20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.20.ebuild,v 1.1 2013/05/08 05:05:35 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="puzzle game similar to Oxyd"
+HOMEPAGE="http://www.nongnu.org/enigma/"
+SRC_URI="mirror://sourceforge/enigma-game/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+COMMON_DEPS="media-libs/sdl-ttf
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libpng:0=
+ sys-libs/zlib
+ net-misc/curl
+ || ( >=dev-libs/xerces-c-3[icu] >=dev-libs/xerces-c-3[-icu,-iconv] )
+ net-libs/enet:0
+ media-fonts/dejavu
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPS}
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPS}
+ x11-misc/xdg-utils"
+
+src_prepare() {
+ rm -rf lib-src/enet
+ cp /usr/share/gettext/config.rpath .
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ sed -i \
+ -e "s:DOCDIR:\"/usr/share/doc/${P}/html\":" \
+ src/main.cc || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ #rm -f "${GAMES_DATADIR}"/${PN}/fonts/DejaVuSansCondensed.ttf
+ dosym \
+ /usr/share/fonts/dejavu/DejaVuSansCondensed.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/DejaVuSansCondensed.ttf
+ dodoc ACKNOWLEDGEMENTS AUTHORS CHANGES README doc/HACKING
+ dohtml -r doc/*
+ doman doc/enigma.6
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/enigma/files/enigma-1.20-autotools.patch b/games-puzzle/enigma/files/enigma-1.20-autotools.patch
new file mode 100644
index 000000000000..632c10ba099a
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.20-autotools.patch
@@ -0,0 +1,132 @@
+diff -ru enigma-1.20.orig/Makefile.am enigma-1.20/Makefile.am
+--- enigma-1.20.orig/Makefile.am 2013-04-01 14:31:58.000000000 -0400
++++ enigma-1.20/Makefile.am 2013-05-07 18:50:08.624851119 -0400
+@@ -3,12 +3,9 @@
+ # tools -> lib-src/lua
+ # src -> tools, lib-src
+ #
+-SUBDIRS = m4 lib-src tools intl src data doc po etc
++SUBDIRS = m4 lib-src tools intl src data po etc
+ EXTRA_DIST = enigma CHANGES ACKNOWLEDGEMENTS
+
+-docdir = @datadir@/doc/enigma
+-doc_DATA = README CHANGES COPYING ACKNOWLEDGEMENTS
+-
+ ACLOCAL_AMFLAGS = -I m4
+
+ .PHONY: tolua
+diff -ru enigma-1.20.orig/configure.ac enigma-1.20/configure.ac
+--- enigma-1.20.orig/configure.ac 2013-04-01 14:33:05.000000000 -0400
++++ enigma-1.20/configure.ac 2013-05-07 18:47:52.420666003 -0400
+@@ -292,7 +292,6 @@
+ CXXFLAGS="$CXXFLAGS -O2 -ffast-math -fomit-frame-pointer"
+ AC_MSG_RESULT(yes)
+ else
+- CXXFLAGS="$CXXFLAGS -g"
+ AC_MSG_RESULT(no)
+ fi
+
+diff -ru enigma-1.20.orig/etc/Makefile.am enigma-1.20/etc/Makefile.am
+--- enigma-1.20.orig/etc/Makefile.am 2013-04-01 14:31:57.000000000 -0400
++++ enigma-1.20/etc/Makefile.am 2013-05-07 18:48:20.707666061 -0400
+@@ -1,14 +1,14 @@
+ # if !MINGW32
+ # Comply with xdg icon theme specification
+-icondir = $(prefix)/share/icons/hicolor/48x48/apps
++icondir = /usr/share/icons/hicolor/48x48/apps
+ icon_DATA = enigma.png
+
+ # Backwards-compatible global search location for images
+-pixmapdir = $(prefix)/share/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = enigma.png
+
+ # Install .desktop file in xdg standard location
+-desktopdir = $(prefix)/share/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = enigma.desktop
+ # endif !MINGW32
+
+diff -ru enigma-1.20.orig/etc/enigma.desktop enigma-1.20/etc/enigma.desktop
+--- enigma-1.20.orig/etc/enigma.desktop 2013-04-01 14:31:57.000000000 -0400
++++ enigma-1.20/etc/enigma.desktop 2013-05-07 18:49:07.889998154 -0400
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Version=1.0
+
+ Name=Enigma
+@@ -8,7 +7,6 @@
+ Comment=Uncover pairs of stones while navigating obstacles using a marble
+ Comment[eo]=Malkovru parojn de ŝtonojn dum vi navigas obstaklojn kun globeto
+
+-FilePattern=enigma;
+ TryExec=enigma
+ Exec=enigma
+ Terminal=false
+@@ -17,5 +15,5 @@
+ StartupNotify=false
+
+ Type=Application
+-Categories=Application;Game;PuzzleGame;
++Categories=Game;X-PuzzleGame;
+
+diff -ru enigma-1.20.orig/lib-src/Makefile.am enigma-1.20/lib-src/Makefile.am
+--- enigma-1.20.orig/lib-src/Makefile.am 2013-04-01 14:33:52.000000000 -0400
++++ enigma-1.20/lib-src/Makefile.am 2013-05-07 18:49:37.009968740 -0400
+@@ -1 +1 @@
+-SUBDIRS = oxydlib lua zipios++ enet enigma-core
++SUBDIRS = oxydlib lua zipios++ enigma-core
+diff -ru enigma-1.20.orig/po/Makefile.in.in enigma-1.20/po/Makefile.in.in
+--- enigma-1.20.orig/po/Makefile.in.in 2013-04-01 14:34:35.000000000 -0400
++++ enigma-1.20/po/Makefile.in.in 2013-05-07 18:50:47.291484194 -0400
+@@ -25,12 +25,12 @@
+ exec_prefix = @exec_prefix@
+ datarootdir = @datarootdir@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = $(top_srcdir)/mkinstalldirs
+ #install_sh@ -d
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+diff -ru enigma-1.20.orig/src/Makefile.am enigma-1.20/src/Makefile.am
+--- enigma-1.20.orig/src/Makefile.am 2013-04-01 14:33:59.000000000 -0400
++++ enigma-1.20/src/Makefile.am 2013-05-07 18:51:50.173261187 -0400
+@@ -12,12 +12,11 @@
+ CXXFLAGS = @CXXFLAGS@\
+ -DSYSTEM_DATA_DIR=\"$(datadir)/enigma\" \
+ -DDOCDIR=\"$(docdir)\" \
+- -DLOCALEDIR=\"$(localedir_enigma)\" \
++ -DLOCALEDIR=\"/usr/share/locale\" \
+ -I$(top_srcdir)/lib-src/zipios++ \
+ -I$(top_builddir)/lib-src/zipios++ \
+ -I$(top_srcdir)/lib-src/lua \
+ -I$(top_srcdir)/lib-src/enigma-core \
+- -I$(top_srcdir)/lib-src/enet/include \
+ -I$(top_srcdir)/lib-src \
+ -I$(top_builddir)/intl @SDL_CFLAGS@
+
+@@ -433,7 +432,7 @@
+
+ else # not MINGW32
+
+- localedir_enigma := $(datadir)/locale
++ localedir_enigma := /usr/share/locale
+ mingw_ldadd =
+
+ endif
+@@ -442,7 +441,7 @@
+ @LIBINTL@ \
+ $(top_builddir)/lib-src/enigma-core/libecl.a \
+ $(top_builddir)/lib-src/lua/liblua.a \
+- $(top_builddir)/lib-src/enet/libenet.a \
++ -lenet \
+ $(top_builddir)/lib-src/oxydlib/liboxyd.a \
+ $(top_builddir)/lib-src/zipios++/src/libzipios.a \
+ -lz \