summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-05-22 08:52:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-05-22 08:52:18 +0000
commit065292ab14c4701d32b44e23b1630ef6cce92a0a (patch)
treebd8923b0f93df7335c2918642fa474f3536cc074 /games-puzzle/enigma
parentVersion bump (diff)
downloadgentoo-2-065292ab14c4701d32b44e23b1630ef6cce92a0a.tar.gz
gentoo-2-065292ab14c4701d32b44e23b1630ef6cce92a0a.tar.bz2
gentoo-2-065292ab14c4701d32b44e23b1630ef6cce92a0a.zip
Fix build with gcc-4.4.0 Bug #269275
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle/enigma')
-rw-r--r--games-puzzle/enigma/ChangeLog16
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild3
-rw-r--r--games-puzzle/enigma/files/enigma-1.01-gcc44.patch40
3 files changed, 52 insertions, 7 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index cdb8cc7b9d9b..91de512e082a 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/enigma
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.43 2009/01/12 06:19:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.44 2009/05/22 08:52:18 tupone Exp $
+
+ 22 May 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/enigma-1.01-gcc44.patch, enigma-1.01.ebuild:
+ Fix build with gcc-4.4.0 Bug #269275
12 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> enigma-1.01.ebuild:
EAPI=2; add use-based dep for media-libs/sdl-image (bug #206393)
@@ -12,7 +16,7 @@
18 Nov 2008; Michael Sterrett <mr_bones_@gentoo.org>
+files/enigma-1.01-xerces-c.patch, enigma-1.01.ebuild:
- add patch for building with xerces-c-3 from Frédéric COIFFIER via bug #242916
+ add patch for building with xerces-c-3 from Frédéric COIFFIER via bug #242916
18 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org> enigma-1.01.ebuild:
new tarball from upstream for 64-bit support (bug #235076)
@@ -28,7 +32,7 @@
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+files/enigma-1.01-gcc43.patch, enigma-1.01.ebuild:
- Patch to fix building with gcc-4.3 from Martin Väth, bug #218941
+ Patch to fix building with gcc-4.3 from Martin Väth, bug #218941
*enigma-1.01 (04 Nov 2007)
@@ -176,16 +180,16 @@
*enigma-0.40a (21 Jun 2002)
- 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> enigma-0.40a.ebuild :
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> enigma-0.40a.ebuild :
Added KEYWORDS.
- 21 Jun 2002; J.Alberto Suárez L. <bass@gentoo.org> enigma-0.40a.ebuild:
+ 21 Jun 2002; J.Alberto Suárez L. <bass@gentoo.org> enigma-0.40a.ebuild:
Bumped version of Larry Cow,fixed problems with gcc3.
*enigma-0.39a (28 Apr 2002)
- 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> enigma-0.39a.ebuild :
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> enigma-0.39a.ebuild :
Added LICENSE, KEYWORDS, SLOT.
28 Apr 2002; Ryan Phillips <rphillips@gentoo.org> enigma-0.39a.ebuild :
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
index dc3e049f4b3c..75b4ca082141 100644
--- a/games-puzzle/enigma/enigma-1.01.ebuild
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.10 2009/01/12 06:19:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.11 2009/05/22 08:52:18 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -30,6 +30,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-autotools.patch \
"${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-xerces-c.patch
eautoreconf
}
diff --git a/games-puzzle/enigma/files/enigma-1.01-gcc44.patch b/games-puzzle/enigma/files/enigma-1.01-gcc44.patch
new file mode 100644
index 000000000000..4695ec4f2118
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.01-gcc44.patch
@@ -0,0 +1,40 @@
+--- src/PropertyManager.cc.old 2009-05-22 10:50:04.000000000 +0200
++++ src/PropertyManager.cc 2009-05-22 10:50:30.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include "XMLtoLocal.hh"
+ #include "XMLtoUtf8.hh"
+ #include "ecl_system.hh"
++#include <cstdio>
+ #include <iostream>
+ #include <xercesc/dom/DOM.hpp>
+ #include <xercesc/util/XMLDouble.hpp>
+--- src/StateManager.cc.old 2009-05-22 10:52:13.000000000 +0200
++++ src/StateManager.cc 2009-05-22 10:52:38.000000000 +0200
+@@ -31,6 +31,7 @@
+ #include "XMLtoUtf8.hh"
+ #include "ecl_system.hh"
+ #include "gui/ErrorMenu.hh"
++#include <cstdio>
+ #include <iostream>
+ #include <sstream>
+ #include <xercesc/dom/DOM.hpp>
+--- src/gui/LevelPackComposer.cc.old 2009-05-22 10:53:46.000000000 +0200
++++ src/gui/LevelPackComposer.cc 2009-05-22 10:54:24.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include "lev/Index.hh"
+
+ #include "main.hh"
++#include <cstdio>
+
+ using namespace ecl;
+ using namespace std;
+--- src/lev/Index.cc.old 2009-05-22 10:55:16.000000000 +0200
++++ src/lev/Index.cc 2009-05-22 10:55:41.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include "StateManager.hh"
+ #include "lev/ScoreManager.hh"
+ #include "lev/RatingManager.hh"
++#include <cstdio>
+
+
+ namespace enigma { namespace lev {