summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 13:11:33 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 13:11:33 +0000
commite28ec185f9e38a7872928ef8ac46ac7316c1d076 (patch)
tree539edd4b40aa039d4d430a0bc1ec7b99d4df428d /games-puzzle/construo
parentAdd nightly beta 2008-05-01; remove comment about svn ver from 7.0 (diff)
downloadgentoo-2-e28ec185f9e38a7872928ef8ac46ac7316c1d076.tar.gz
gentoo-2-e28ec185f9e38a7872928ef8ac46ac7316c1d076.tar.bz2
gentoo-2-e28ec185f9e38a7872928ef8ac46ac7316c1d076.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-puzzle/construo')
-rw-r--r--games-puzzle/construo/ChangeLog8
-rw-r--r--games-puzzle/construo/construo-0.2.2.ebuild20
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
3 files changed, 96 insertions, 14 deletions
diff --git a/games-puzzle/construo/ChangeLog b/games-puzzle/construo/ChangeLog
index 83fa9222c0d0..10b220ec2750 100644
--- a/games-puzzle/construo/ChangeLog
+++ b/games-puzzle/construo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/construo
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/ChangeLog,v 1.12 2007/12/26 10:17:11 drac Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/ChangeLog,v 1.13 2008/05/01 13:11:32 nyhm Exp $
+
+ 01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/construo-0.2.2-gcc43.patch, construo-0.2.2.ebuild:
+ Fix building with gcc-4.3
26 Dec 2007; Samuli Suominen <drac@gentoo.org> construo-0.2.2.ebuild:
amd64 stable wrt #201403
diff --git a/games-puzzle/construo/construo-0.2.2.ebuild b/games-puzzle/construo/construo-0.2.2.ebuild
index cd10e0fe2c70..6df7cd0f6736 100644
--- a/games-puzzle/construo/construo-0.2.2.ebuild
+++ b/games-puzzle/construo/construo-0.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.13 2007/12/26 10:17:11 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.14 2008/05/01 13:11:32 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="2d construction toy with objects that react on physical forces"
HOMEPAGE="http://www.nongnu.org/construo/"
@@ -15,18 +15,14 @@ IUSE=""
RDEPEND="x11-libs/libSM
x11-libs/libXxf86vm
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- x11-proto/xf86vidmodeproto
x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i \
- -e 's:<math.h>:<cmath>:g' vector.cxx \
- || die "sed failed"
-
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {
@@ -35,10 +31,10 @@ src_compile() {
}
src_install() {
- make \
+ emake \
DESTDIR="${D}" \
bindir="${GAMES_BINDIR}" install \
- || die "make install failed"
+ || die "emake install failed"
dodoc AUTHORS NEWS README TODO
prepgamesdirs
}
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..cc946b043bae
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -0,0 +1,82 @@
+--- command_line.cxx
++++ command_line.cxx
+@@ -19,7 +19,9 @@
+
+ #include <config.h>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+ #include "settings.hxx"
+ #include "command_line.hxx"
+
+--- config.hxx
++++ config.hxx
+@@ -21,6 +21,7 @@
+ #define CONFIG_HH
+
+ #include <string>
++#include <cstdlib>
+
+ class Config
+ {
+--- lisp_reader.cxx
++++ lisp_reader.cxx
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstring>
+ #include "construo_error.hxx"
+ #include "lisp_reader.hxx"
+
+--- unix_system.cxx
++++ unix_system.cxx
+@@ -17,8 +17,9 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <stdio.h>
+-#include <assert.h>
++#include <cstdio>
++#include <cassert>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <time.h>
+--- vector.cxx
++++ vector.cxx
+@@ -16,8 +16,8 @@
+ totally replaced old CL_Vector with this code
+ */
+
+-#include <assert.h>
+-#include <math.h>
++#include <cassert>
++#include <cmath>
+ #include "vector.hxx"
+
+ CL_Vector::CL_Vector(float x, float y, float z, float w)
+--- world.cxx
++++ world.cxx
+@@ -17,7 +17,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <assert.h>
++#include <cassert>
++#include <cstring>
+ #include <algorithm>
+ #include "config.h"
+
+--- x11_display.cxx
++++ x11_display.cxx
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <iostream>
++#include <cstring>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>