summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-12-03 07:55:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-12-03 07:55:11 +0000
commit469cf408bae5b973e5a1e2686a59c0769fac38a1 (patch)
treef0a6de0e42f6e56cc20dde86b1b6983a576635a2 /games-puzzle/bastet
parentVersion bump (diff)
downloadgentoo-2-469cf408bae5b973e5a1e2686a59c0769fac38a1.tar.gz
gentoo-2-469cf408bae5b973e5a1e2686a59c0769fac38a1.tar.bz2
gentoo-2-469cf408bae5b973e5a1e2686a59c0769fac38a1.zip
Version bump to 0.43 Bug #320381
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/bastet')
-rw-r--r--games-puzzle/bastet/ChangeLog10
-rw-r--r--games-puzzle/bastet/bastet-0.43.ebuild35
-rw-r--r--games-puzzle/bastet/files/bastet-0.43-gentoo.patch15
3 files changed, 58 insertions, 2 deletions
diff --git a/games-puzzle/bastet/ChangeLog b/games-puzzle/bastet/ChangeLog
index 895587b1a50c..3d8ece3dd65c 100644
--- a/games-puzzle/bastet/ChangeLog
+++ b/games-puzzle/bastet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/bastet
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/ChangeLog,v 1.9 2009/02/08 18:27:16 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/ChangeLog,v 1.10 2010/12/03 07:55:11 tupone Exp $
+
+*bastet-0.43 (02 Dec 2010)
+
+ 02 Dec 2010; Tupone Alfredo <tupone@gentoo.org> +bastet-0.43.ebuild,
+ +files/bastet-0.43-gentoo.patch:
+ Version bump to 0.43 Bug #320381 by hitachi
08 Feb 2009; Tupone Alfredo <tupone@gentoo.org>
+files/bastet-0.41-as-needed.patch, bastet-0.41.ebuild:
diff --git a/games-puzzle/bastet/bastet-0.43.ebuild b/games-puzzle/bastet/bastet-0.43.ebuild
new file mode 100644
index 000000000000..9c84acf3a315
--- /dev/null
+++ b/games-puzzle/bastet/bastet-0.43.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/bastet-0.43.ebuild,v 1.1 2010/12/03 07:55:11 tupone Exp $
+
+EAPI=2
+inherit toolchain-funcs eutils games
+
+DESCRIPTION="a simple, evil, ncurses-based Tetris(R) clone"
+HOMEPAGE="http://fph.altervista.org/prog/bastet.shtml"
+SRC_URI="http://fph.altervista.org/prog/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake CXX=$(tc-getCC) || die "make failed"
+}
+
+src_install() {
+ dogamesbin bastet || die "dogamesbin failed"
+ doman bastet.6
+ dodoc AUTHORS NEWS README
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/bastet.scores" || die "touch failed"
+ fperms 664 "${GAMES_STATEDIR}/bastet.scores"
+ prepgamesdirs
+}
diff --git a/games-puzzle/bastet/files/bastet-0.43-gentoo.patch b/games-puzzle/bastet/files/bastet-0.43-gentoo.patch
new file mode 100644
index 000000000000..db7671592224
--- /dev/null
+++ b/games-puzzle/bastet/files/bastet-0.43-gentoo.patch
@@ -0,0 +1,15 @@
+--- Makefile.old 2010-12-02 15:43:29.000000000 +0100
++++ Makefile 2010-12-02 15:47:18.000000000 +0100
+@@ -11,10 +11,10 @@
+ depend: *.hpp $(SOURCES)
+ $(CXX) -MM $(SOURCES) > depend
+
+-include depend
++-include depend
+
+ $(PROGNAME): $(SOURCES:.cpp=.o)
+- $(CXX) -ggdb -o $(PROGNAME) $(SOURCES:.cpp=.o) $(LDFLAGS) -lboost_program_options
++ $(CXX) ${CXXFLAGS} -o $(PROGNAME) $(SOURCES:.cpp=.o) $(LDFLAGS) -lboost_program_options
+
+ clean:
+ rm -f $(SOURCES:.cpp=.o) $(PROGNAME)