summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit2f7b073c1bc54c873666c4522cd6cd49ac1d59df (patch)
tree072f3e7b49f6b078b595b1483277009b1f03d0f6 /games-puzzle/4stattack
parentgames-puzzle (diff)
downloadgentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.gz
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.bz2
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/4stattack')
-rw-r--r--games-puzzle/4stattack/4stattack-2.1.4.ebuild41
-rw-r--r--games-puzzle/4stattack/ChangeLog10
-rw-r--r--games-puzzle/4stattack/Manifest5
-rw-r--r--games-puzzle/4stattack/files/4stattack3
-rw-r--r--games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff55
-rw-r--r--games-puzzle/4stattack/files/digest-4stattack-2.1.41
6 files changed, 115 insertions, 0 deletions
diff --git a/games-puzzle/4stattack/4stattack-2.1.4.ebuild b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
new file mode 100644
index 000000000000..f13bcfeec439
--- /dev/null
+++ b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/4stattack-2.1.4.ebuild,v 1.1 2003/09/10 06:35:59 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Connect-4 game, single or network multiplayer"
+HOMEPAGE="http://forcedattack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/forcedattack/4stAttack-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-python/pygame-1.5"
+
+S=${WORKDIR}/4stAttack-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # move the doc files aside so it's easier to install the game files
+ mv README.txt credits.txt changelog.txt ..
+ rm GPL version~
+
+ #This patch makes the game save settings in $HOME instead
+ # of in /usr/share/games
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_install() {
+ dogamesbin ${FILESDIR}/4stattack
+ dosed "s:GENTOO_DIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/4stattack
+ dodoc ../README.txt ../credits.txt ../changelog.txt
+
+ dodir ${GAMES_DATADIR}/4stattack
+ cp -R * ${D}/${GAMES_DATADIR}/4stattack/
+
+ prepgamesdirs
+}
diff --git a/games-puzzle/4stattack/ChangeLog b/games-puzzle/4stattack/ChangeLog
new file mode 100644
index 000000000000..3a4287c185cb
--- /dev/null
+++ b/games-puzzle/4stattack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-games/4stattack
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/ChangeLog,v 1.1 2003/09/10 06:35:59 vapier Exp $
+
+*4stattack-2.1.4 (30 Jul 2003)
+
+ 30 Jul 2003; Michael Sterrett <msterret@gentoo.org> 4stattack-2.1.4.ebuild:
+ initial commit. ebuild and patch supplied by Rob Cakebread via bug 25229 then
+ modified a bit.
+
diff --git a/games-puzzle/4stattack/Manifest b/games-puzzle/4stattack/Manifest
new file mode 100644
index 000000000000..4fc9725cb570
--- /dev/null
+++ b/games-puzzle/4stattack/Manifest
@@ -0,0 +1,5 @@
+MD5 0042001873ffd1ee94e39a06a6ba3baf files/4stattack 80
+MD5 a38f167d6d78ba1c79320f6c2f4f9754 files/4stattack-2.1.4-gentoo.diff 1316
+MD5 12ea5a9c56c11d99d09e20829d830263 files/digest-4stattack-2.1.4 68
+MD5 fdb70429805cabd30efe93d5d8935f09 4stattack-2.1.4.ebuild 1101
+MD5 4f9913e300558b5fa291c22dc0abb9a8 ChangeLog 432
diff --git a/games-puzzle/4stattack/files/4stattack b/games-puzzle/4stattack/files/4stattack
new file mode 100644
index 000000000000..c0b761b3b44c
--- /dev/null
+++ b/games-puzzle/4stattack/files/4stattack
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec /usr/bin/env python GENTOO_DIR/4stattack.py "${@}"
diff --git a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
new file mode 100644
index 000000000000..a6b77993dc00
--- /dev/null
+++ b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
@@ -0,0 +1,55 @@
+--- 4stAttack-2.1.4/4stattack.py 2002-10-01 07:38:03.000000000 -0700
++++ new/4stattack.py 2003-07-24 22:11:34.000000000 -0700
+@@ -28,6 +28,9 @@
+ images = None
+ screen = None
+
++f = os.path.expanduser('~/.4stattackrc')
++if not os.path.exists(f):
++ os.system('cp /usr/share/games/4stattack/settings.ini %s' % f)
+
+ def playMusic(datadir):
+ if pygame.mixer.get_init():
+@@ -49,11 +52,11 @@
+ screen = pygame.display.set_mode(resolution, FULLSCREEN)
+ else:
+ screen = pygame.display.set_mode(resolution)
+-
++
+ pygame.display.set_caption('4st Attack 2')
+ pygame.mouse.set_visible(1)
+ pygame.display.init()
+-
++
+ pygame.display.Info()
+ return screen
+
+@@ -72,21 +75,21 @@
+ pygame.quit()
+ os._exit(0)
+
+-def main():
++def main():
+ options = getOptions(sys.argv)
+-
++
+ if options.has_key('-ini'):
+ ini_settings = IniSettings(options['-ini'])
+ else:
+- ini_settings = IniSettings('settings.ini')
+-
++ ini_settings = IniSettings(os.path.expanduser('~/.4stattackrc'))
++
+ settings = ini_settings.settings
+-
++
+ datadir = settings['path']['data']
+-
++
+ if settings['sound']['music'] == 'yes':
+ playMusic(datadir)
+-
++
+ resolution = settings['video']['resolution']
+ res = string.split(resolution, 'x')
+ screen = setDisplay((int(res[0]), int(res[1])), settings['video']['fullscreen'])
diff --git a/games-puzzle/4stattack/files/digest-4stattack-2.1.4 b/games-puzzle/4stattack/files/digest-4stattack-2.1.4
new file mode 100644
index 000000000000..ba5d8878f826
--- /dev/null
+++ b/games-puzzle/4stattack/files/digest-4stattack-2.1.4
@@ -0,0 +1 @@
+MD5 72a6d85d4218e938c043a6e5f0074e1b 4stAttack-2.1.4.tar.gz 1828247