summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-23 00:19:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-23 00:19:15 +0000
commit94011a44925e631451172572f582c3cd6e3e0e51 (patch)
tree8e73cde9c1e0692e6fb9a05e40357f05f3665fe1 /games-mud
parentRemove arm keywords (Manifest recommit) (diff)
downloadgentoo-2-94011a44925e631451172572f582c3cd6e3e0e51.tar.gz
gentoo-2-94011a44925e631451172572f582c3cd6e3e0e51.tar.bz2
gentoo-2-94011a44925e631451172572f582c3cd6e3e0e51.zip
initial ebuild #37586
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/xpertmud/ChangeLog8
-rw-r--r--games-mud/xpertmud/files/digest-xpertmud-3.1_pre11
-rw-r--r--games-mud/xpertmud/metadata.xml16
-rw-r--r--games-mud/xpertmud/xpertmud-3.1_pre1.ebuild35
4 files changed, 60 insertions, 0 deletions
diff --git a/games-mud/xpertmud/ChangeLog b/games-mud/xpertmud/ChangeLog
new file mode 100644
index 000000000000..72a41707f920
--- /dev/null
+++ b/games-mud/xpertmud/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-mud/xpertmud
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.1 2004/02/23 00:19:15 vapier Exp $
+
+*xpertmud-3.1_pre1 (22 Feb 2004)
+
+ 22 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Jens Hoffrichter #37586.
diff --git a/games-mud/xpertmud/files/digest-xpertmud-3.1_pre1 b/games-mud/xpertmud/files/digest-xpertmud-3.1_pre1
new file mode 100644
index 000000000000..8a9f214f7aef
--- /dev/null
+++ b/games-mud/xpertmud/files/digest-xpertmud-3.1_pre1
@@ -0,0 +1 @@
+MD5 c8dc5df62c5b9e70cbdf1802810e46c5 xpertmud-3.1preview1.tar.bz2 773108
diff --git a/games-mud/xpertmud/metadata.xml b/games-mud/xpertmud/metadata.xml
new file mode 100644
index 000000000000..910a188a11d3
--- /dev/null
+++ b/games-mud/xpertmud/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Xpertmud is an extensible perl and python scriptable MUD client. It is based on Qt and
+KDE. There's a native Linux/KDE version as well as a native Windows/Win32 build. This
+enables you to use the same script on your Linux box at home and on your Windows box at
+work...
+
+It supports multiple windows (which are scriptable), and you can use triggers, aliases or
+whatever you want on every bit of text that comes from or goes to the server. There's a
+stable and intuitive plugin API, so you can extend the client with Qt-based C++ code. A
+sample plugin for the btech MUX is included.
+</longdescription>
+</pkgmetadata>
diff --git a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
new file mode 100644
index 000000000000..5834dc90737a
--- /dev/null
+++ b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.1 2004/02/23 00:19:15 vapier Exp $
+
+inherit kde
+need-kde 3
+
+MY_PV="${PV/_pre/preview}"
+DESCRIPTION="the eXtensible Python pErl Ruby scripTable MUD client"
+HOMEPAGE="http://xpertmud.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xpertmud/xpertmud-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="python ruby"
+
+DEPEND=">=sys-devel/libperl-5.6.1
+ python? ( >=dev-lang/python-2.2 )
+ ruby? ( >=dev-lang/ruby-1.8.0 )"
+
+S=${WORKDIR}/xpertmud-${MY_PV}
+
+src_compile() {
+ econf \
+ `use_with python python` \
+ `use_with ruby ruby` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog DESIGN NEWS README TODO
+}