summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-09 18:43:53 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-09 18:43:53 +0000
commit922ee9ce88ec2ef8c5dc833f4c174dfddad3ae82 (patch)
treef5fc4c05b3417cf0ca4c417842cd233b1d86d3fd /games-mud
parentuse games_get_libdir (diff)
downloadgentoo-2-922ee9ce88ec2ef8c5dc833f4c174dfddad3ae82.tar.gz
gentoo-2-922ee9ce88ec2ef8c5dc833f4c174dfddad3ae82.tar.bz2
gentoo-2-922ee9ce88ec2ef8c5dc833f4c174dfddad3ae82.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/tkmoo/tkmoo-0.3.32.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-mud/tkmoo/tkmoo-0.3.32.ebuild b/games-mud/tkmoo/tkmoo-0.3.32.ebuild
index 0696da2852ab..ab0f8557279c 100644
--- a/games-mud/tkmoo/tkmoo-0.3.32.ebuild
+++ b/games-mud/tkmoo/tkmoo-0.3.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tkmoo/tkmoo-0.3.32.ebuild,v 1.12 2007/03/13 01:31:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tkmoo/tkmoo-0.3.32.ebuild,v 1.13 2007/04/09 18:43:53 nyhm Exp $
inherit eutils games
@@ -18,7 +18,7 @@ IUSE=""
DEPEND=">=dev-lang/tcl-8.3.3
>=dev-lang/tk-8.3.3"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
@@ -30,17 +30,17 @@ src_unpack() {
src_compile() {
emake \
WISH="$(type -P wish)" \
- TKMOO_LIB_DIR="${GAMES_LIBDIR}/${MY_PN}" \
+ TKMOO_LIB_DIR="$(games_get_libdir)/${MY_PN}" \
TKMOO_BIN_DIR="${GAMES_BINDIR}" \
|| die "emake failed"
}
src_install() {
- make \
- TKMOO_LIB_DIR="${D}/${GAMES_LIBDIR}/${MY_PN}" \
+ emake \
+ TKMOO_LIB_DIR="${D}/$(games_get_libdir)/${MY_PN}" \
TKMOO_BIN_DIR="${D}/${GAMES_BINDIR}" \
install \
- || die "make install failed"
+ || die "emake install failed"
dodoc README dot.tkmoolightrc bugsmail.txt
dosym tkMOO-lite "${GAMES_BINDIR}/tkmoo"
prepgamesdirs