summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-01 14:34:36 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-01 14:34:36 +0000
commit8edb9581b5ede80a07dffa6fe4cbe1d9db0fdd7d (patch)
tree489f37b3681277325dec93586c165321267bc5d5 /games-mud
parentMove kde-misc/print-manager to kde-base/print-manager. (diff)
downloadgentoo-2-8edb9581b5ede80a07dffa6fe4cbe1d9db0fdd7d.tar.gz
gentoo-2-8edb9581b5ede80a07dffa6fe4cbe1d9db0fdd7d.tar.bz2
gentoo-2-8edb9581b5ede80a07dffa6fe4cbe1d9db0fdd7d.zip
use python-single-r1, bump EAPI
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/wxmud/ChangeLog7
-rw-r--r--games-mud/wxmud/wxmud-9999.ebuild30
2 files changed, 24 insertions, 13 deletions
diff --git a/games-mud/wxmud/ChangeLog b/games-mud/wxmud/ChangeLog
index 6309e3df37cd..082f0bfb7d34 100644
--- a/games-mud/wxmud/ChangeLog
+++ b/games-mud/wxmud/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-mud/wxmud
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/wxmud/ChangeLog,v 1.5 2011/03/27 13:19:58 nirbheek Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/wxmud/ChangeLog,v 1.6 2013/04/01 14:34:36 hasufell Exp $
+
+ 01 Apr 2013; Julian Ospald <hasufell@gentoo.org> wxmud-9999.ebuild:
+ use python-single-r1, bump EAPI
27 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> wxmud-9999.ebuild:
Fix slot-dep on gtk+
diff --git a/games-mud/wxmud/wxmud-9999.ebuild b/games-mud/wxmud/wxmud-9999.ebuild
index ca9758adc6cf..75db7fbaccee 100644
--- a/games-mud/wxmud/wxmud-9999.ebuild
+++ b/games-mud/wxmud/wxmud-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/wxmud/wxmud-9999.ebuild,v 1.5 2011/03/27 13:19:58 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/wxmud/wxmud-9999.ebuild,v 1.6 2013/04/01 14:34:36 hasufell Exp $
+
+EAPI=5
-EAPI="1"
WX_GTK_VER=2.8
-inherit flag-o-matic subversion wxwidgets autotools games
+PYTHON_COMPAT=( python2_{5,6,7} )
+inherit flag-o-matic subversion wxwidgets autotools python-single-r1 games
DESCRIPTION="Cross-platform MUD client"
HOMEPAGE="http://wxmud.sourceforge.net/"
@@ -16,28 +18,34 @@ SLOT="0"
KEYWORDS=""
IUSE="python"
-RDEPEND="=x11-libs/wxGTK-2.8*
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}
>=x11-libs/gtk+-2.4:2
- python? ( >=dev-lang/python-2.4 )"
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
+pkg_setup() {
+ games_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
src_unpack() {
subversion_src_unpack
- cd "${S}"
+ cd "${S}" || die
AT_M4DIR="m4" eautoreconf
}
src_compile() {
append-flags -fno-strict-aliasing
# No audiere in portage yet, so useful MSP support is disabled for now
- egamesconf --with-wx-config="${WX_CONFIG}" \
+ egamesconf \
+ --with-wx-config="${WX_CONFIG}" \
$(use_enable python) \
--disable-audiere
- emake || die "emake failed"
+ emake
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README TODO docs/input.txt docs/scripting.txt || die
+ default
+ dodoc docs/input.txt docs/scripting.txt
prepgamesdirs
}