summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-15 20:51:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-15 20:51:52 +0000
commit30cba2b7d67eab2024c7b4b54b76970df30413ed (patch)
tree7f9b4692b7761e3d0dc1de1cb1e21d5c1d0ffaf6 /games-mud/xpertmud
parentVersion bump. (diff)
downloadgentoo-2-30cba2b7d67eab2024c7b4b54b76970df30413ed.tar.gz
gentoo-2-30cba2b7d67eab2024c7b4b54b76970df30413ed.tar.bz2
gentoo-2-30cba2b7d67eab2024c7b4b54b76970df30413ed.zip
EAPI=2; remove arts; compile with kde4 installed (bug #285124)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-mud/xpertmud')
-rw-r--r--games-mud/xpertmud/ChangeLog8
-rw-r--r--games-mud/xpertmud/xpertmud-3.1_pre1.ebuild19
2 files changed, 15 insertions, 12 deletions
diff --git a/games-mud/xpertmud/ChangeLog b/games-mud/xpertmud/ChangeLog
index 2e19b8133b13..acad6e0eef3d 100644
--- a/games-mud/xpertmud/ChangeLog
+++ b/games-mud/xpertmud/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/xpertmud
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.9 2009/01/21 14:02:36 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.10 2009/09/15 20:51:52 mr_bones_ Exp $
+
+ 15 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ xpertmud-3.1_pre1.ebuild:
+ EAPI=2; remove arts; compile with kde4 installed (bug #285124)
21 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+files/xpertmud-3.1_pre1-gcc43.patch, xpertmud-3.1_pre1.ebuild:
diff --git a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
index 6826bb374143..f8df5d7b5319 100644
--- a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
+++ b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.10 2009/01/21 14:02:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.11 2009/09/15 20:51:52 mr_bones_ Exp $
-ARTS_REQUIRED="yes"
+EAPI=2
inherit eutils kde
MY_PV="${PV/_pre/preview}"
@@ -12,33 +12,32 @@ SRC_URI="mirror://sourceforge/xpertmud/xpertmud-${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE="python ruby"
DEPEND=">=sys-devel/libperl-5.6.1
python? ( >=dev-lang/python-2.2 )
ruby? ( >=dev-lang/ruby-1.8.0 )"
+
need-kde 3
S=${WORKDIR}/xpertmud-${MY_PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}"-gcc34.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}"/${P}-gcc43.patch
}
-src_compile() {
+src_configure() {
econf \
+ --without-arts \
$(use_with python python) \
$(use_with ruby ruby) \
- || die
- emake || die "emake failed"
+ --with-extra-includes=$(kde-config --expandvars --install include)
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog DESIGN NEWS README TODO
}