summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-27 21:09:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-27 21:09:58 +0000
commit9cbd9b72d29e7aebdeec116fc9d9656e01db3cb5 (patch)
tree1eefa0751c77e4056db7dbac0b48bac034675385 /games-mud/tf
parentRemove some old versions. (diff)
downloadgentoo-2-9cbd9b72d29e7aebdeec116fc9d9656e01db3cb5.tar.gz
gentoo-2-9cbd9b72d29e7aebdeec116fc9d9656e01db3cb5.tar.bz2
gentoo-2-9cbd9b72d29e7aebdeec116fc9d9656e01db3cb5.zip
add patch to work around libpcre changes submitted by Robert Varga via bug #409779
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-mud/tf')
-rw-r--r--games-mud/tf/ChangeLog9
-rw-r--r--games-mud/tf/files/tf-50_beta8-pcre.patch61
-rw-r--r--games-mud/tf/tf-50_beta8-r1.ebuild6
3 files changed, 71 insertions, 5 deletions
diff --git a/games-mud/tf/ChangeLog b/games-mud/tf/ChangeLog
index 64ebdb573232..6e10f29ecdc5 100644
--- a/games-mud/tf/ChangeLog
+++ b/games-mud/tf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-mud/tf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.23 2011/10/01 03:19:26 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.24 2012/05/27 21:09:58 mr_bones_ Exp $
+
+ 27 May 2012; Michael Sterrett <mr_bones_@gentoo.org> tf-50_beta8-r1.ebuild,
+ +files/tf-50_beta8-pcre.patch:
+ add patch to work around libpcre changes submitted by Robert Varga via bug
+ #409779
01 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> tf-50_beta8-r1.ebuild:
x86 stable wrt bug #381735
diff --git a/games-mud/tf/files/tf-50_beta8-pcre.patch b/games-mud/tf/files/tf-50_beta8-pcre.patch
new file mode 100644
index 000000000000..4ff5e44db91b
--- /dev/null
+++ b/games-mud/tf/files/tf-50_beta8-pcre.patch
@@ -0,0 +1,61 @@
+From f61b5859d69c2d99264182f60f5ae1e430812b59 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
+Date: Fri, 10 Feb 2012 13:55:46 +0100
+Subject: [PATCH] Fix build with PCRE-8.30+
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch fixes build with the latest PCRE release which removes some
+obsolete code tinyfugue still uses, namely pcre_info().
+
+Signed-off-by: Petr Šabata <contyk@redhat.com>
+---
+ src/macro.c | 3 ++-
+ src/pattern.c | 2 +-
+ src/pattern.h | 2 +-
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/src/macro.c b/src/macro.c
+index ac28fc9..b492717 100644
+--- a/src/macro.c
++++ b/src/macro.c
+@@ -893,7 +893,8 @@ static int complete_macro(Macro *spec, unsigned int hash, int num,
+ }
+ spec->attr &= ~F_NONE;
+ if (spec->nsubattr) {
+- int n = pcre_info(spec->trig.ri->re, NULL, NULL);
++ int n;
++ pcre_fullinfo(spec->trig.ri->re, NULL, PCRE_INFO_CAPTURECOUNT, &n);
+ for (i = 0; i < spec->nsubattr; i++) {
+ spec->subattr[i].attr &= ~F_NONE;
+ if (spec->subattr[i].subexp > n) {
+diff --git a/src/pattern.c b/src/pattern.c
+index 047a44a..a7228ff 100644
+--- a/src/pattern.c
++++ b/src/pattern.c
+@@ -151,7 +151,7 @@ static RegInfo *tf_reg_compile_fl(const char *pattern, int optimize,
+ emsg ? emsg : "unknown error");
+ goto tf_reg_compile_error;
+ }
+- n = pcre_info(ri->re, NULL, NULL);
++ pcre_fullinfo(ri->re, NULL, PCRE_INFO_CAPTURECOUNT, &n);
+ if (n < 0) goto tf_reg_compile_error;
+ ri->ovecsize = 3 * (n + 1);
+ ri->ovector = dmalloc(NULL, sizeof(int) * ri->ovecsize, file, line);
+diff --git a/src/pattern.h b/src/pattern.h
+index 1eec0f9..cbe9af9 100644
+--- a/src/pattern.h
++++ b/src/pattern.h
+@@ -10,7 +10,7 @@
+ #ifndef PATTERN_H
+ #define PATTERN_H
+
+-#include "pcre-2.08/pcre.h"
++#include <pcre.h>
+
+ typedef struct RegInfo {
+ pcre *re;
+--
+1.7.7.6
+
diff --git a/games-mud/tf/tf-50_beta8-r1.ebuild b/games-mud/tf/tf-50_beta8-r1.ebuild
index 7009c09e8768..ec74f40817a2 100644
--- a/games-mud/tf/tf-50_beta8-r1.ebuild
+++ b/games-mud/tf/tf-50_beta8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-50_beta8-r1.ebuild,v 1.2 2011/10/01 03:19:26 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-50_beta8-r1.ebuild,v 1.3 2012/05/27 21:09:58 mr_bones_ Exp $
EAPI=2
inherit games
@@ -26,7 +26,7 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-PATCHES=( "${DISTDIR}"/tf-all*patch.txt )
+PATCHES=( "${DISTDIR}"/tf-all*patch.txt "${FILESDIR}"/${P}-pcre.patch )
src_configure() {
STRIP=: egamesconf \