summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:03:12 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:03:12 +0000
commitdadcbe068c35d74868010de7a74a50c5eef228c7 (patch)
tree71bf44569e2e5655fa0f404f5f2252964a7c7ae7 /games-mud/mcl
parentumodpack is in games-util now (diff)
downloadgentoo-2-dadcbe068c35d74868010de7a74a50c5eef228c7.tar.gz
gentoo-2-dadcbe068c35d74868010de7a74a50c5eef228c7.tar.bz2
gentoo-2-dadcbe068c35d74868010de7a74a50c5eef228c7.zip
welcome to games-mud
Diffstat (limited to 'games-mud/mcl')
-rw-r--r--games-mud/mcl/ChangeLog11
-rw-r--r--games-mud/mcl/Manifest4
-rw-r--r--games-mud/mcl/files/digest-mcl-0.52.991
-rw-r--r--games-mud/mcl/files/mcl-0.52.99-gcc3.patch70
-rw-r--r--games-mud/mcl/mcl-0.52.99.ebuild38
5 files changed, 124 insertions, 0 deletions
diff --git a/games-mud/mcl/ChangeLog b/games-mud/mcl/ChangeLog
new file mode 100644
index 000000000000..a7c4446dd27f
--- /dev/null
+++ b/games-mud/mcl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-games/mcl
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/ChangeLog,v 1.1 2003/09/10 19:03:12 vapier Exp $
+
+*mcl-0.52.99.ebuild (8 Aug 2002)
+
+ 30 Sep 2002; Mike Frysinger <vapier@gentoo.org> mcl-0.52.99-gcc3.patch :
+ Added a patch so this compiles under gcc3.x and cleaned up the ebuild
+
+ 8 Aug 2002; J. Alberto Suárez López <bass@gentoo.org> mcl-0.52.99.ebuild :
+ First relase.
diff --git a/games-mud/mcl/Manifest b/games-mud/mcl/Manifest
new file mode 100644
index 000000000000..06a3746cf597
--- /dev/null
+++ b/games-mud/mcl/Manifest
@@ -0,0 +1,4 @@
+MD5 caa20a86a84d88634adda0e85feda4f3 ChangeLog 483
+MD5 3d5c24664d1bfe4e3a3ff2d8fb3e1314 mcl-0.52.99.ebuild 1021
+MD5 56b5a91a0c408a64428baefb19467472 files/digest-mcl-0.52.99 67
+MD5 4f3f1fc9565c922ce92d26da8a9de07b files/mcl-0.52.99-gcc3.patch 2162
diff --git a/games-mud/mcl/files/digest-mcl-0.52.99 b/games-mud/mcl/files/digest-mcl-0.52.99
new file mode 100644
index 000000000000..8f8fff43f682
--- /dev/null
+++ b/games-mud/mcl/files/digest-mcl-0.52.99
@@ -0,0 +1 @@
+MD5 21785179349e2648bda2ccb98025a79e mcl-0.52.99-src.tar.gz 210227
diff --git a/games-mud/mcl/files/mcl-0.52.99-gcc3.patch b/games-mud/mcl/files/mcl-0.52.99-gcc3.patch
new file mode 100644
index 000000000000..d4183bd8f75f
--- /dev/null
+++ b/games-mud/mcl/files/mcl-0.52.99-gcc3.patch
@@ -0,0 +1,70 @@
+--- ./h/Config.h.orig 2002-09-30 23:41:19.000000000 -0400
++++ ./h/Config.h 2002-09-30 23:41:53.000000000 -0400
+@@ -94,7 +94,7 @@
+ String string_options[max_option];
+
+
+- friend MUDSelection; // messes with mud_list
++ friend struct MUDSelection; // messes with mud_list
+
+ time_t save_time; // When was .mclrc last modifed?
+
+--- ./h/Window.h.orig 2002-09-30 23:41:28.000000000 -0400
++++ ./h/Window.h 2002-09-30 23:42:01.000000000 -0400
+@@ -82,7 +82,7 @@
+ virtual void set_bottom_message (const char *s);
+
+
+- friend Group; // argh
++ friend struct Group; // argh
+
+ Window* find(Window *w); // Is this window still one of my children?
+
+--- ./h/OutputWindow.h.orig 2002-09-30 23:41:33.000000000 -0400
++++ ./h/OutputWindow.h 2002-09-30 23:42:17.000000000 -0400
+@@ -42,7 +42,7 @@
+ } highlight;
+
+ bool fFrozen; // Should we move viewpoint or not?
+- friend ScrollbackController;
++ friend struct ScrollbackController;
+ };
+
+ // This is an invisible object that controls the scrollback process
+--- ./h/Session.h.orig 2002-09-30 23:41:40.000000000 -0400
++++ ./h/Session.h 2002-09-30 23:42:29.000000000 -0400
+@@ -52,9 +52,9 @@
+ mc_state *mcinfo;
+ ColorConverter colorConverter;
+
+- friend NetworkStateWindow;
+- friend StatWindow;
+- friend TimerWindow;
++ friend struct NetworkStateWindow;
++ friend struct StatWindow;
++ friend struct TimerWindow;
+
+ void print(const char *s); // Write to our output/log
+
+--- ./h/Chat.h.orig 2002-09-30 23:42:37.000000000 -0400
++++ ./h/Chat.h 2002-09-30 23:42:45.000000000 -0400
+@@ -196,7 +196,7 @@
+ ChatServerSocket(); // bind to port
+ List<ChatConnection*> connections;
+
+- friend ChatConnection;
++ friend struct ChatConnection;
+ int id; // Stamp ID
+ bool is_afk;
+ int snoop_count;
+--- Makefile.orig 2002-09-30 23:53:50.000000000 -0400
++++ Makefile 2002-09-30 23:54:02.000000000 -0400
+@@ -54,7 +54,7 @@
+ LOCAL_CPPFLAGS=-Ih
+ LOCAL_CXXFLAGS=-W -Wall -pipe
+ LOCAL_LDFLAGS=-rdynamic
+-LOCAL_LIBS=
++LOCAL_LIBS=-lstdc++
+
+ # Common flags
+ MCL_CFLAGS=$(CFLAGS) $(CPPFLAGS) $(DEFS) $(LOCAL_CFLAGS) $(LOCAL_CPPFLAGS)
diff --git a/games-mud/mcl/mcl-0.52.99.ebuild b/games-mud/mcl/mcl-0.52.99.ebuild
new file mode 100644
index 000000000000..a00a903624ce
--- /dev/null
+++ b/games-mud/mcl/mcl-0.52.99.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.52.99.ebuild,v 1.1 2003/09/10 19:03:12 vapier Exp $
+
+IUSE="python perl"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A console MUD client scriptable in Perl and Python"
+SRC_URI="http://www.andreasen.org/mcl/dist/${P}-src.tar.gz"
+HOMEPAGE="http://www.andreasen.org/mcl/"
+LICENSE="GPL-2"
+DEPEND="perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+KEYWORDS="x86"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use perl && myconf="${myconf} --enable-perl" || myconf="${myconf} --disable-perl"
+ use python && myconf="${myconf} --enable-python" || myconf="${myconf} --disable-python"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man $myconf || die "./configure failed"
+
+ patch -p0<${FILESDIR}/mcl-0.52.99-gcc3.patch
+
+ emake || die
+}
+
+src_install () {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc doc/*
+}