summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-25 17:58:31 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-25 17:58:31 +0000
commit6772d1c5faa9f8ca4dd67aba7e19062d9b505fda (patch)
treedbc4ec89bbff4e054af441880758e24e1b3f7180 /games-mud/kmuddy
parentAdd USE=selinux dependency on SELinux asterisk policy module package (diff)
downloadgentoo-2-6772d1c5faa9f8ca4dd67aba7e19062d9b505fda.tar.gz
gentoo-2-6772d1c5faa9f8ca4dd67aba7e19062d9b505fda.tar.bz2
gentoo-2-6772d1c5faa9f8ca4dd67aba7e19062d9b505fda.zip
Bump to EAPI 4, add patch to fix (most) .desktop validation warnings.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'games-mud/kmuddy')
-rw-r--r--games-mud/kmuddy/files/kmuddy-1.0.1-desktopvalidation.patch84
-rw-r--r--games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild3
-rw-r--r--games-mud/kmuddy/kmuddy-1.0.1-r2.ebuild35
3 files changed, 120 insertions, 2 deletions
diff --git a/games-mud/kmuddy/files/kmuddy-1.0.1-desktopvalidation.patch b/games-mud/kmuddy/files/kmuddy-1.0.1-desktopvalidation.patch
new file mode 100644
index 000000000000..428dc94fc789
--- /dev/null
+++ b/games-mud/kmuddy/files/kmuddy-1.0.1-desktopvalidation.patch
@@ -0,0 +1,84 @@
+--- kmuddy/kmuddy.desktop
++++ kmuddy/kmuddy.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ Name=KMuddy
+ Type=Application
+ Exec=kmuddy -caption "%c" %i %m
+--- libs/kmuddyplugin.desktop
++++ libs/kmuddyplugin.desktop
+@@ -1,6 +1,6 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Type=ServiceType
++Name=KMuddy Plugins
+ X-KDE-ServiceType=KMuddy/Plugin
+ X-KDE-Derived=KPluginInfo
+ Comment=KMuddy Plugin
+--- plugins/converter/kmuddyconverterplugin.desktop
++++ plugins/converter/kmuddyconverterplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Profile Converter
+ Comment=This plug-in converts profiles from old KMuddy versions.
+ ServiceTypes=KMuddy/Plugin
+--- plugins/mapper/plugins/standard/kmuddymapper_standard.desktop
++++ plugins/mapper/plugins/standard/kmuddymapper_standard.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Type=Service
+-Comment=The standard mapper tools and views
+ Name=Standard
+ Comment=The standard mapper tools and views
+ ServiceTypes=KMuddy/Mapper/Plugin
+--- plugins/scripting/kmuddyscriptingplugin.desktop
++++ plugins/scripting/kmuddyscriptingplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=External Scripting
+ Comment=Adds support for external scripting.
+ ServiceTypes=KMuddy/Plugin
+--- plugins/strings/kmuddystringsplugin.desktop
++++ plugins/strings/kmuddystringsplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Strings
+ Comment=This plug-in adds many strings functions.
+ ServiceTypes=KMuddy/Plugin
+--- plugins/test/kmuddytestplugin.desktop
++++ plugins/test/kmuddytestplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Testing Plug-in
+ Comment=Testing Plug-in
+ ServiceTypes=KMuddy/Plugin
+--- plugins/vartrigs/kmuddyvartrigplugin.desktop
++++ plugins/vartrigs/kmuddyvartrigplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Variable Triggers
+ Comment=Adds supports for triggers that fire off variable changes.
+ ServiceTypes=KMuddy/Plugin
+--- plugins/varviewer/kmuddyvarviewerplugin.desktop
++++ plugins/varviewer/kmuddyvarviewerplugin.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Variable Viewer
+ Comment=This plug-in provides a variable viewer window.
+ ServiceTypes=KMuddy/Plugin
+--- template/kmuddyplugintemplate.desktop
++++ template/kmuddyplugintemplate.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Plugin Template
+ Comment=Plugin Template
+ ServiceTypes=KMuddy/Plugin
diff --git a/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild b/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild
index 635459285be4..74e8436167ee 100644
--- a/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild
+++ b/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild,v 1.4 2012/03/06 20:40:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-1.0.1-r1.ebuild,v 1.5 2012/08/25 17:58:31 creffett Exp $
EAPI=3
@@ -25,7 +25,6 @@ PATCHES=(
"${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-tempnam.patch
)
-
src_configure() {
# not in portage yet
mycmakeargs+=(
diff --git a/games-mud/kmuddy/kmuddy-1.0.1-r2.ebuild b/games-mud/kmuddy/kmuddy-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..b88a71bd24e5
--- /dev/null
+++ b/games-mud/kmuddy/kmuddy-1.0.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-1.0.1-r2.ebuild,v 1.1 2012/08/25 17:58:31 creffett Exp $
+
+EAPI=4
+
+KDE_LINGUAS="es"
+KDE_DOC_DIRS="doc/${PN}"
+KDE_HANDBOOK=optional
+inherit kde4-base
+
+DESCRIPTION="MUD client for KDE"
+HOMEPAGE="http://www.kmuddy.com/"
+SRC_URI="http://www.kmuddy.com/releases/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DOC="AUTHORS README CHANGELOG Scripting-HOWTO TODO DESIGN"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-{gcc,kde}45.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-tempnam.patch
+ "${FILESDIR}"/${P}-desktopvalidation.patch
+)
+src_configure() {
+ # not in portage yet
+ mycmakeargs+=(
+ -DWITH_MXP=OFF
+ )
+ kde4-base_src_configure
+}