summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-01 20:02:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-01 20:02:28 +0000
commitb3970d67d1932873637818c12536b12a2ea8b7b6 (patch)
tree2625566649c6b1fb635734fe38019bb5a54e5e54 /games-misc
parentsync live ebuild md5 rules with 195. (diff)
downloadgentoo-2-b3970d67d1932873637818c12536b12a2ea8b7b6.tar.gz
gentoo-2-b3970d67d1932873637818c12536b12a2ea8b7b6.tar.bz2
gentoo-2-b3970d67d1932873637818c12536b12a2ea8b7b6.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog8
-rw-r--r--games-misc/opengfx/opengfx-0.4.5.ebuild41
2 files changed, 47 insertions, 2 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index 77cf8c69d876..7bd0653c8a32 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.23 2012/06/27 17:43:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.24 2012/11/01 20:02:28 mr_bones_ Exp $
+
+*opengfx-0.4.5 (01 Nov 2012)
+
+ 01 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +opengfx-0.4.5.ebuild:
+ version bump
27 Jun 2012; Markus Meier <maekke@gentoo.org> opengfx-0.4.4.ebuild:
add ~arm, bug #412329
@@ -92,4 +97,3 @@
+opengfx-0.2.3.ebuild, +metadata.xml:
initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko via bug
#300328
-
diff --git a/games-misc/opengfx/opengfx-0.4.5.ebuild b/games-misc/opengfx/opengfx-0.4.5.ebuild
new file mode 100644
index 000000000000..03ae943b4a4b
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.5.ebuild,v 1.1 2012/11/01 20:02:28 mr_bones_ Exp $
+
+EAPI=4
+inherit games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=games-util/nml-0.2.3"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ sed -i \
+ -e 's:echo "gimp":echo "":g' \
+ scripts/Makefile.def || die
+}
+
+src_compile() {
+ emake bundle
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}